Opened 6 years ago

Closed 6 years ago

#8658 closed Bug (worksforme)

a better solution for #1659

Reported by: yiminghe Owned by:
Priority: Normal Milestone:
Component: Core : Selection Version: 3.0
Keywords: Cc:

Description

  1. input the following html in ie:
<p>
	1234567890</p>
  1. click the area as shown in 1.jpg

expected result:

cursor positioned as shown in expected.jpg (same with other browsers)

actual result:

cursor positioned as shown in actual.jpg

PS : i provide a patch which solution came from tinymce , i think it's better.

Attachments (4)

1.png (12.7 KB) - added by yiminghe 6 years ago.
actual.png (5.5 KB) - added by yiminghe 6 years ago.
expected.png (1.4 KB) - added by yiminghe 6 years ago.
20120111.patch (5.5 KB) - added by yiminghe 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by yiminghe

Attachment: 1.png added

Changed 6 years ago by yiminghe

Attachment: actual.png added

Changed 6 years ago by yiminghe

Attachment: expected.png added

Changed 6 years ago by yiminghe

Attachment: 20120111.patch added

comment:1 Changed 6 years ago by Jakub Ś

Keywords: ie cursor removed
Status: newconfirmed
Version: 3.6.3 (SVN - trunk)3.0

It works as expected for IE so I guess it's worth looking at the patch provided by a user. Confirming the ticket.

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 6 years ago by Jakub Ś

I did a quick test and it seems that patch from #7932 has fixed this issue.

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: confirmedclosed

It works for me as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy