Ticket #8702 (closed New Feature: invalid)

Opened 2 years ago

Last modified 8 weeks ago

Mono support

Reported by: Anna Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version: 3.5.2
Keywords: Cc:

Description

The CKEditor for ASP.NET control does not work under Mono. Reported here: http://cksource.com/forums/viewtopic.php?f=6&t=24610

Is there any reason the .NET CKEditor control should not work under Mono? I have several other .NET plugins working such as ImageResizer, that work fine.

The CKEditor plugin works great on my local machine, but when I deploy the solution to my Apache server with mod_mono plugin, I get a normal text area loading in the page, with no CKEditor.

I am fairly new to Mono, so I may have missed a step or done something stupid.

Any ideas or things I should check?

Change History

comment:1 Changed 2 years ago by Anna

  • Status changed from new to confirmed

comment:2 Changed 8 weeks ago by Reinmar

  • Type changed from Bug to New Feature

comment:3 Changed 8 weeks ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

Looks like user has already solved his problem. Looking at his last post (pasted below) there is nothing else to do but closing this issue as invalid because what user has described are actually basic steps to get editor installed on page.

I have solved the issue, thanks to someone on the mono mailing list.

In case anyone is interested, here are the steps:

(1) Download and unzip all files into a sub folder of your ASP.NET project

(2) Add ckeditor.js to the .aspx page that should display the editor

(3) Add the following code to your .aspx page:

<asp:TextBox ID="TextBox1" runat="server" CssClass="ckeditor" Height="299px" Width="100%" TextMode="MultiLine"></asp:TextBox>

Works perfectly!

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy