Ticket #8701 (closed Bug: fixed)

Opened 2 years ago

Last modified 2 years ago

Highlight field in Select Color dialog not showing correct color when we navigate Colors using keyboard

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: General Version: 3.3
Keywords: IBM Cc: damo, tmonahan

Description

To reproduce the defect:

  1. Open any CK Editor sample & insert a table.
  1. Open Context menu and click on Cell -> Cell Properties option.
  1. Cell Properties dialog opened.
  1. Click on Choose button next to Background Color.
  1. Select Color dialog opened.
  1. Now navigate through the Colors list using keyboard and verify the Color shown in the Highlight field.

Issue: Highlight field always showing the last color that we navigated.

I have attached a screenshot of the error

Attachments

Color Highlighter Error.jpg (25.9 KB) - added by satya 2 years ago.
8701.patch (2.8 KB) - added by garry.yao 2 years ago.

Change History

Changed 2 years ago by satya

comment:1 Changed 2 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.3

Issue has been reproducible from CKEditor 3.3 (when moving with arrows was implemented)

My observation:

  • Put the cursor in one of first cells on the left E.g. 6th row (color - #0000ff)
  • Start moving to the right with arrow key
  • Hightlighted color is one color behind.

Despite 1 color being late:

  • After pressing arrow key 7 times you should reach #3300ff
  • Color #3300ff is next to #00ffff so pressing left arrow should move the hightlight to #00ffff

Actual Result:
Highlight will be moved to the right first (probably because of this one late right arrow press)
So when you are on #3300ff and you start pressing left arrow the result is as follows: #3333ff (color on the right),#3300ff, #00ffff (color on the left.)

comment:2 Changed 2 years ago by j.swiderski

Other tickets that fall under Select "Color Dialog Problems / Enchancements":
#8706, #8698, #8519, #8679, #8523, #8218, #5960, #4994.

Last edited 2 years ago by j.swiderski (previous) (diff)

Changed 2 years ago by garry.yao

comment:3 Changed 2 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review
  • Milestone set to CKEditor 3.6.3

comment:4 Changed 2 years ago by fredck

  • Status changed from review to review_passed

comment:5 Changed 2 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed by #8698.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy