Opened 6 years ago

Closed 6 years ago

#8714 closed Bug (invalid)

forcePasteAsPlainText option doesn't work in Firefox when copying from another website

Reported by: Lukas Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.6.2
Keywords: Cc:

Description

If you copy formatted text from another website and paste it into a CKEditor, the text will be pasted formatted even though the option forcePasteAsPlainText is set to true. I'm using Firefox 10.0 on MacOs X 10.6.7 .

Steps to reproduce:

1) Copy formatted text from another website like http://www.nytimes.com/ . I have tried copying from Firefox and Chrome 2) Paste it into CKEditor using Firefox 3) Formatting should be pasted too

Copying formatted text from a text-editor (like OS X's TextEdit) works correctly, the formatting will be removed

Change History (2)

comment:1 Changed 6 years ago by Lukas

Ok it may be that the problem is that the textarea (#pastebin), that is used to paste the clipboard-data to in FF, must not be invisible. You put it outside the viewport. But because sometimes FF scrolls to that textarea when it is given the focus (often named "ambiguous page scroll" in the forums) i did not move it outside the viewport, but gave it display: hidden.

If I hide the textarea forcePasteAsPlainText doesn't work (and it doesn't work in your online-demo either!). If I show the textarea it woks like a charm.

comment:2 Changed 6 years ago by Jakub Ś

Keywords: forcePasteAsPlainText removed
Resolution: invalid
Status: newclosed

I have found your post describing solution to scroll in Firefox -http://cksource.com/forums/viewtopic.php?f=6&t=23247. It seems that solution you have proposed is causing this error as without it forcePasteAsPlainText works as expected.

In that case this is not a valid bug as your custom fix has caused it. I will have to close it.

Problems with scrolling in Firefox and MAC were mentioned in this ticket - http://dev.ckeditor.com/ticket/8409.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy