Ticket #8744 (closed Bug: fixed)

Opened 2 years ago

Last modified 2 years ago

FF10 Mac insertHtml causes {cke_protected}

Reported by: goofygrin Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.1
Keywords: Cc:

Description

This was working fine in FF7 Mac (and works fine in Chrome, IE, etc.). FF10 Mac seems to have broken it.

I have a plugin that runs this command: editor.insertHtml("<!--readmore-->");

When I run this in FF10 Mac, I get indeterminate results. Sometimes it works fine. Sometimes it makes entire paragraphs get wrapped into a cke_protected block (and disappear), sometimes I get {ckw_protected}{C}.

This is likely a continuation of this ticket unfortunately: http://dev.ckeditor.com/ticket/5309

Attachments

Archive.zip (922.1 KB) - added by goofygrin 2 years ago.
simple sample

Change History

comment:1 Changed 2 years ago by j.swiderski

  • Status changed from new to pending

I have tried your example but did not get the result you are having.

Could you tell me:

  1. what settings have you used to configure CKEditor?
  2. Are you by any chance using protected Source?
  3. Coudl you give me more detailed description - like what is inside CKEditor, what gets pasted and where exactly?
  4. Is the issue by any chance reproducible in API sample which uses inserHTML method?

comment:2 Changed 2 years ago by goofygrin

  1. Here's how I include it in my page:

<script type='text/javascript' src='/ckeditor/ckeditor.js'></script>

<script type='text/javascript' src='/ckeditor/adapters/jquery.js'></script>

<script>

$(document).ready(function () {

$('textarea.editor').ckeditor();

});

</script>

  1. I'm using the code right off the site (albeit 0.0.1 out of date). I'm not sure what protected source means (closed source? I've not changed any of the source code)
  2. This is starting with a <textarea> that has no content.
  3. Not sure what you're referring to...

Here's my entire plugin code:

(function () {

var o = {

exec: function (editor) {

editor.insertHtml("<!--readmore-->");

}

}; CKEDITOR.plugins.add('readmore',

{

init: function (editor) {

var pluginName = 'readmore'; editor.addCommand(pluginName, o); editor.ui.addButton('readmore',

{

label: 'Read More for Articles', command: pluginName, icon: this.path + 'readmore.png'

});

}

});

})();

comment:3 Changed 2 years ago by goofygrin

I'm uploading a sample test case that fails in FF Mac.

Simply run this, enter two lines of text (foo, bar so that the source is foo<br />bar) then move your cursor up the end of foo and click the icon on the last row, bottom (looks like three windows). The first paragraph disappears.

Changed 2 years ago by goofygrin

simple sample

comment:4 Changed 2 years ago by j.swiderski

I have checked this issue with and without your plugin but didn't get disappearing result nor protected source. I have tested this issue in FF11 and FF12 on Mac 10.7.

Some tags like php or JavaScript can be made protected - not available in WYSIWYG mode - http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html#.protectedSource but this is not the case here as you haven't used this option

There are some problems with HTML comments or unwanted 'protected' and {C} but none of this looks like your issue: http://dev.ckeditor.com/search?q={C}&noquickjump=1&ticket=on

Could you tell me if this problem still persist in your application? If answer is yes, is there anything else that might be causing this problem, any setting you haven’t told me about?

comment:5 Changed 2 years ago by goofygrin

With FF11 Mac I no longer have the issue.

comment:6 Changed 2 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to fixed

Thank you for the feedback. Closing the ticket as it has expired with newer version of Firefox.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy