Ticket #8751 (closed Bug: expired)

Opened 2 years ago

Last modified 2 years ago

Links is escaped with bbcode!!

Reported by: AlmogBaku Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by j.swiderski) (diff)

Steps to reproduce:

  1. enter to ckeditor with bbcode enabled: http://nightly.ckeditor.com/7364/_samples/bbcode.html
  2. try to enter link with ampersand like http://dev.ckeditor.com/newticket?type=Bug&bug=Swear_once_more_and_get_banned
  3. click on "Source"
  4. See whats happend to the url!!

~Almog

I've also tried to fix it by config:

CKEDITOR.config.forceSimpleAmpersand=true; CKEDITOR.config.basicEntities=false;

and on the instance config too

Change History

comment:1 Changed 2 years ago by j.swiderski

  • Keywords bug, argent, ampersand, bbcode removed
  • Status changed from new to pending
  • Version 3.6.3 (SVN - trunk) deleted
  • Description modified (diff)

@AlmogBaku I have just checked your issue in bbcode sample.

It seems that the only way to insert link is through link dialog and I haven't seen any ampersand change. Could you tell me in which browser and which OS are you getting this?

comment:2 Changed 2 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to expired

comment:3 Changed 2 years ago by AlmogBaku

still not fixed!!

I am using Firefox at windows 7

comment:4 Changed 2 years ago by j.swiderski

still not fixed!!

In comment no.1 I have asked you for some details as I was not able to reproduce the problem. Two months have passed and you haven't replied - ticket has expired because of lack of your response.

Please provide more details to this ticket screenshots, screencast, answers to my questions. I will check it then and will reopen this ticket if I'm able to reproduce it.

comment:5 Changed 2 years ago by krajicek

Hi there,

i experience the same problem here (version 3.6.2) - i use bbcode sample from _sample/ folder.

when in Link dialog is entered URL containing ampersand (&) this is converted into url encoded & when editor mode is switched between wysiwyg and source modes.

i am on xp and bug appears in FF9, chrome16 & IE7

if you need any more details pls let me know

thanks in advance

Last edited 2 years ago by krajicek (previous) (diff)

comment:6 Changed 2 years ago by krajicek

  • Keywords bbcode ampersand "&" added

comment:7 Changed 2 years ago by krajicek

  • Keywords & added; "&" removed

comment:8 Changed 2 years ago by Anna

  • Keywords bbcode ampersand & removed

comment:9 Changed 2 years ago by j.swiderski

Hi @krajicek,

I have checked your problem but didn't get the result you were talking about.
I have found out however that link can't be exited and may be destroyed when you modify it: #8995 and #8994.

Is this the problem you were having or it is different? If it is different could you provide detailed scenario, configuration options used and perhaps a screen cast?

comment:10 Changed 2 years ago by AlmogBaku

Hey There! I've record a screencast of the bug: http://screenr.com/5tX8

Thanks and Shabbath Shalom. ~ Almog.

comment:11 Changed 2 years ago by j.swiderski

Thank for the screencast - now I see what you have meant.

This is actually the same situation as described here #8995 - you modify the link and it gets destroyed.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy