Opened 7 years ago

Closed 3 years ago

#8780 closed Bug (fixed)

Copy Paste Word 2010, Cleanup Internal Error

Reported by: Syslogic Owned by:
Priority: Normal Milestone: CKEditor 4.5.3
Component: Plugin : Paste from Word Version: 3.5.3
Keywords: IBM Cc: fzuo@…, satya_minnekanti@…

Description

Made a word document with a table and some formatting in a column (most notable a numbered list). When I try to copy-past the table I get a "It was not possible to clean up the pasted data due to an internal error."

I've tried the copy/paste in the demo editor and in the nightly.ckeditor.com and both give the same error. The table b.t.w. is pasted correctly (visually) but when looking at the code the MS-Word formatting is still there.

Attachments (1)

ckeditor_tablebug_document.docx (15.2 KB) - added by Syslogic 7 years ago.
The table that triggers the copy/paste bug

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by Syslogic

The table that triggers the copy/paste bug

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed
Version: 3.5.3

Reproducible from CKEditor 3.5.3 rev [6616] Seems that enhanced list handling has problems with lists in tables for Office Word 2010 documents. The same table created in Word 2003 works without problems.

comment:2 Changed 7 years ago by Jakub Ś

Other tickets caused by [6616] revision: #7982, #8516, #8136

comment:3 Changed 5 years ago by Jakub Ś

Problem can still be reproduced in latest CKEditor 4.x (4.1.1 at the time of writing).

comment:4 Changed 5 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:5 Changed 5 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word

comment:6 Changed 3 years ago by Jakub Ś

Please see http://dev.ckeditor.com/ticket/12740#comment:3 - there might be one source of the problem.

comment:7 Changed 3 years ago by Tade0

The problem was caused by the fact, that apparently handling the tab-stops style was done according to this spec: http://www.w3.org/People/howcome/t/970224HTMLERB-CSS/WD-tabs-970117.html

And the real value of that style is usually something similar to "36pt", "22px" etc.

Please follow #13590 for further information.

comment:8 Changed 3 years ago by Piotrek Koszuliński

Cc: fzuo@… added

Closed #9685 as a DUP of this issue.

comment:9 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.3
Resolution: fixed
Status: confirmedclosed

Fixed by #13590.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy