Opened 7 years ago

Closed 4 years ago

#9685 closed Bug (duplicate)

MS-WORD copy paste error from "ckeditor_tablebug_document.docx​" attached

Reported by: Feng Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.5.3
Keywords: Cc: fzuo@…, satya_minnekanti@…

Description

Hi CKEditor team,

We integrated CKEditor 3.6 to our product but would like to report a bug.

Bug description:

  1. I have a table copy-paste from WORD 93-2007 doc (see attachment).
  2. Click on "Paste from Word" icon.
  3. Copy table (CTRL+C) then paste into the popup in CKEditor.
  4. CKEditor has a error: "It was not possible to clean up the pasted data due to an internal error." message.

This issue is reproducible on http://ckeditor.com/demo (which is 3.6.5.) I believe it is because of the some of the format inside the table cell that contains extra tags that can't be parsed by ckeditor therefore bringing the error message.

Thanks, Feng Zuo

Attachments (2)

ckeditor_tablebug_document.docx (15.2 KB) - added by Feng 7 years ago.
testResumeTest.docx (12.1 KB) - added by Feng 7 years ago.
sample word doc for test

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Feng

Changed 7 years ago by Feng

Attachment: testResumeTest.docx added

sample word doc for test

comment:1 Changed 7 years ago by Feng

Cc: fzuo@… added
Keywords: MS WORD added; Word removed
Summary: MS WORD copy paste error[IE9 only] MS WORD copy paste error

comment:2 Changed 7 years ago by Feng

Summary: [IE9 only] MS WORD copy paste error[IE9 only] MS-WORD copy paste error from "ckeditor_tablebug_document.docx​" attached

comment:3 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

adding myself to cc

comment:4 Changed 7 years ago by Jakub Ś

Keywords: MS WORD removed
Status: newconfirmed
Summary: [IE9 only] MS-WORD copy paste error from "ckeditor_tablebug_document.docx​" attachedMS-WORD copy paste error from "ckeditor_tablebug_document.docx​" attached
Version: 3.6.53.5.3

Problem can be reproduced in all browsers except Chrome from CKEditor 3.5.3 rev. [6616]. An enhanced pasting lists from Word was introduced in this revision.

Please note that problem occurs also in CKE 4.x (v4).

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Component: Core : PastingPlugin : Paste from Word

comment:6 Changed 4 years ago by Jakub Ś

Please see http://dev.ckeditor.com/ticket/12740#comment:3 - there might be one source of the problem.

comment:7 Changed 4 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: confirmedclosed

This is a duplicate of #8780 which contains exactly the same file.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy