Opened 6 years ago

Closed 6 years ago

#9686 closed Bug (fixed)

Missing content style for <pre>

Reported by: Garry Yao Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.0.1
Component: Documentation & Samples Version: 4.0 Beta
Keywords: Cc:

Description

<pre> didn't get styled from this change, especially considering the white-space attribute, which helps to eliminate the overflow.

Change History (7)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

I was able to reproduce this problem in Opera, Firefox and IE (7-10) from CKEditor 4 beta.

To reproduce:

  1. Go to replacebyclass sample
  2. Click inside second paragraph (Amstrong spent about...)
  3. Choose "Formatted" from Format Dropdown

comment:2 Changed 6 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:3 Changed 6 years ago by Olek Nowodziński

Status: assignedreview

Created branch cksource t/9686.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_failed

I think that all we need is:

white-space: pre-wrap; /* CSS 2.1 */
word-wrap: break-word; /* IE7 */

That seems to be enough for samples (see samples/sample.css), so should be enough for editor as well.

Also - we can think of setting tab size to 4, which is more normal then 8. However, that would introduce difference between how that looks on modern browsers and old ones. So much probably we shouldn't do that.

comment:5 in reply to:  4 Changed 6 years ago by Olek Nowodziński

Status: review_failedreview

Replying to Reinmar:

I think that all we need is:

white-space: pre-wrap; /* CSS 2.1 */
word-wrap: break-word; /* IE7 */

That seems to be enough for samples (see samples/sample.css), so should be enough for editor as well.

Right. Pushed a commit for this.

Also - we can think of setting tab size to 4, which is more normal then 8. However, that would introduce difference between how that looks on modern browsers and old ones. So much probably we shouldn't do that.

A separate ticket.

comment:6 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I tested these styles on all supported browsers. Everything seems to be fine.

comment:7 Changed 6 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Masterized fix git:15c12e4.

Extracted tab size thread to #9776.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy