Opened 7 years ago

Last modified 6 years ago

#9687 confirmed Bug

[Safari] Open font-name combo in <pre> crashes browser

Reported by: Garry Yao Owned by:
Priority: Low Milestone:
Component: General Version: 4.0
Keywords: Safari6 Cc:

Description

  1. Load editor with the following source:
    <pre>^foo</pre>
    
  2. Open Font Name combo;
  • Actual: Browser crashes

Reproduced with Safari6 on Mac.

Change History (9)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Status: newpending

I couldn't reproduce this. Safari 6, Mac, preformatted block, caret at the beginning, I'm opening font name combo and everything work.

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

WFM as well.

comment:3 Changed 7 years ago by Jakub Ś

I have tried with the below code:

<textarea cols="80" id="editor1" name="editor1" rows="10">
<pre>foo</pre>
</textarea>

var e = CKEDITOR.replace( 'editor1' );
e.on('instanceReady', function(evt){ //I have also tried clicking and tabbing
evt.editor.focus();
});

I have tried this on Safari 5 and it worked. Can anyone verify Safari 6 with above (if you have used the same please leave a comment that it works)?

comment:4 Changed 7 years ago by Garry Yao

Status: pendingnew

Ok, I figured out that it would require the <pre> being created in the DOM to reproduce it, so revised a bit the TC:

  1. Open replacebyclass in Safari6, Mac
  2. Make a text selection, select pre-formatted from the Format combo;
  3. Now open "Font Name" combo.

Can you re-checked?

comment:5 Changed 7 years ago by Piotrek Koszuliński

Status: newconfirmed

This is how I was checking it. I haven't used source mode.

But now I'm testing it again on second Mac and I can reproduce it. Caret may be anywhere in that <pre> and Safari crashes.

comment:6 Changed 7 years ago by Jakub Ś

Keywords: Safari6 added

Just a note - I'm not getting this on Safari 5.

comment:7 Changed 7 years ago by Piotrek Koszuliński

More details:

  • reporoducible: Safari 6.0.2 7536.26.17
  • not reproducible: Safari 6.0.2 8536.26.17

comment:8 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0

So as this issue should be fixed with the newest Safari builds I'm removing milestone.

comment:9 Changed 6 years ago by Piotrek Koszuliński

Priority: NormalLow
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy