Opened 5 years ago

Closed 5 years ago

#8836 closed Bug (fixed)

IE: Script error when opening table context menu

Reported by: Teresa Monahan Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: UI : Context Menu Version: 3.6.3
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

To Reproduce:

  • Open any nightly sample and insert a table.
  • Click on the table border so that the browser handles appear.
  • Move the mouse over a table cell and right click to bring up the context menu. (See attached screen capture)
  • Move the mouse slightly away from the context menu and click the mouse.

Problem: A script error occurs

When run in source mode, the error is as follows:

Message: Member not found.

Line: 685
Char: 4
Code: 0
URI: ..../_source/plugins/selection/plugin.js

This only seems to occur since revision #7404

Attachments (2)

IE_table_context_menu.gif (12.7 KB) - added by Teresa Monahan 5 years ago.
8836.patch (984 bytes) - added by Garry Yao 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by Teresa Monahan

Attachment: IE_table_context_menu.gif added

comment:1 Changed 5 years ago by Frederico Caldeira Knabben

Component: GeneralUI : Context Menu
Milestone: CKEditor 3.6.3
Status: newconfirmed

Confirmed with IE9+Compat. Ok with IE9.

Confirmed as caused by [7404].

Changed 5 years ago by Garry Yao

Attachment: 8836.patch added

comment:2 Changed 5 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

Looks like we just step on an mine of IE7 selection range bug, where nativeRange.item(0) is error prune.

comment:3 Changed 5 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:4 Changed 5 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [7423].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy