Opened 7 years ago

Closed 7 years ago

#8837 closed Bug (fixed)

p tags getting added inside list items (li) items in outer list

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.3
Keywords: IBM Cc: Damian, Teresa Monahan

Description

Steps to reproduce:

  1. Open Ajax sample and click on Bulleted list icon in the toolbar.
  1. Bulleted list starts.
  1. Type some text, press enter and click on Increase Indent icon.
  1. Nested Bulleted list starts.
  1. Type some text and then press enter twice.

Expected Result: Cursor exists out of Nested Bulleted list and a new list item(li) starts in outer Bulleted list.

Issue: A p tag getting added inside list item (li) that was created inside outerlist and this is creating extra speace between list items.

It's a regression and it's only started happening from revision 7419

  1. Type some text and press enter

Expected Result: A new list item(li) starts in outer Bulleted list.

Issue: A p gets added inside the new list item (li) that was created and same thing happens for all the new list items that are added to outer list.

Same behavious happens with Numbered list as well

Change History (2)

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Status: newpending

It works for me with FF, IE9 and IE9+Compat.

Can you confirm this with the current trunk?

comment:2 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: pendingclosed

Expired on trunk, fixed by [7424].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy