Opened 8 years ago

Closed 8 years ago

#8838 closed Bug (duplicate)

Breaking Markup

Reported by: Mathias Aeschlimann Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Cc:

Description

I have a markup structure set up like this:

 <a href="">
      <div>
        <h2>
        Header</h2>
          <img alt=""
          src="" />
      </div>
    </a>

CKEditor breaks this valid markup and outputs:

      <div>
       <a href="">
        <h2>
        Header</h2></a>
         <a href="">
          <img alt=""
          src="" />
        </a>
      </div>

Change History (2)

comment:1 Changed 8 years ago by Mathias Aeschlimann

I guess the intend here was to produce valid html 4 mark-up. If so, it should at least check the doctype.

Update: I was told at http://wordpress.org/support/topic/plugin-ckeditor-for-wordpress-how-to-stop-ckeditor-from-breaking-my-markup?replies=3#post-2717286 that this behavior is by design. This is very unfortunate, as there is nothing wrong with my mark-up within the doctype I use, so I'd still consider it a bug.

Last edited 8 years ago by Mathias Aeschlimann (previous) (diff)

comment:2 Changed 8 years ago by Jakub Ś

Keywords: html removed
Resolution: duplicate
Status: newclosed

Yes this is valid code for HTML5. It is not yet implemented in v3 of the editor (it should be in v4 by default).

Anyway it has already been reported here #7961

Closing this one as duplicate.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy