Opened 6 years ago

Closed 6 years ago

#8840 closed New Feature (invalid)

Making 'HTML validation and correcting' optional

Reported by: Mathias Aeschlimann Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Cc:

Description

I am told that CKEditor has a HTML validator that is supposed to find invalid markup and try to correct. While this may be a nice thing to have in certain cases, the inability to suppress it, is a big, big, big annoyance. Even more as the validator is ignorant to the doctype and therefore makes wrong assumptions. I just have a case where I wrapped an <a> around a <div> and now CKEditor tries to 'correct' that, as it mistakenly deems it invalid.

HTML validation and correcting should really be optional. And it should be displayed to the user what spec(s) it is checking against if turned on.

Change History (1)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: HTML HTML Validation HTML Validator HTML5 removed
Resolution: invalid
Status: newclosed

I just have a case where I wrapped an <a> around a <div>

This part of a ticket is a duplicate of #7961. We are planning to provide support for HTML5 in CKEditor v4 for which RC version is coming soon.

As for

validation and correcting' optional

It is not possible to do that, because the HTML cleanup is essential to have a proper editing behavior. Without it there would be lot of issues with styles, enterkey behavior etc.

I'm sorry but implementing such feature is impossible.

Closing ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy