Opened 8 years ago

Closed 8 years ago

#8842 closed Bug (invalid)

Urgent - Anchor tags get removed.

Reported by: Lam Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Cc:

Description

I am designing a menu for a customer and when using an empty anchor tag it always get removed.

Below will get removed by CKE. <a href="myurl.com" style="background-url:buttonImage.jpg" /> or <a href="myurl.com" style="background-url:buttonImage.jpg" > </a>

Please dont remove the empty anchor tags.

Thanks, Joe

Change History (2)

comment:1 Changed 8 years ago by Lam

Below will get removed by CKE.

<a href="myurl.com" style="background-url:buttonImage.jpg" />

or

<a href="myurl.com" style="background-url:buttonImage.jpg" > </a>

comment:2 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 3.0 RC3.0

This is how CKEditor works by design - it removes empty inline elements.

To have those elements left in content area links should have at least &nbsp; - <a href="myurl.com" style="background-url:buttonImage.jpg">&nbsp;</a>

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy