Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#8887 closed Bug (fixed)

Kama skin: dialog.css error

Reported by: Alberto Smulders Owned by: Jakub Ś
Priority: Normal Milestone: CKEditor 3.6.4
Component: UI : Skins Version:
Keywords: Firefox Webkit Cc:

Description (last modified by Wiktor Walc)

In Kama.skin - dialog.css, the background position for a.cke_dialog_ui_button should be 0 -1068px instead of 0 -1069px as now, in order to avoid an ugly hover effect (very visible if the default button colors are changed to darker colors in sprites.png - the bad hover effect can be seen for instance on the "Browse Server" button in the image plugin):

line 364 of kawa skin dialog.css

background: transparent url(images/sprites.png) repeat-x scroll 0 -1069px;

should be

background: transparent url(images/sprites.png) repeat-x scroll 0 -1068px;

Attachments (3)

sprites.png (7.3 KB) - added by Alberto Smulders 6 years ago.
button.png (46.4 KB) - added by Jakub Ś 6 years ago.
8887.patch (531 bytes) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by Jakub Ś

very visible if the default button colors are changed to darker colors in sprites.png

Could I ask you to provide this file with darker colors you use?

Changed 6 years ago by Alberto Smulders

Attachment: sprites.png added

comment:2 Changed 6 years ago by Alberto Smulders

The file has been attached. The problem is visible on the 'Browse Server' button in the image plugin. It's also visible in http://ckeditor.com/demo if you click to insert an image with the original sprites.png file - if you watch carefully on mouse-over of the 'Browse Server' button, you'll see the yellow mouse-over like jumping in relation to the blue non-mouse-over. If you open the sprites.png with e.g. photoshop and zoom in, you'll see the blue background starts at pixel-Y 1068 (counting from 0), not 1069.

comment:3 Changed 6 years ago by Jakub Ś

Keywords: kawa dialog dialog_ui_button removed
Status: newconfirmed
Version: 3.6.2

Thank you for pointing that out, now I can see it clearly.

To reproduce just hover over the BrowseServer Button and observe the bottom line (See button.png)

Changed 6 years ago by Jakub Ś

Attachment: button.png added

comment:4 Changed 6 years ago by Jakub Ś

Owner: set to Jakub Ś
Status: confirmedassigned

Changed 6 years ago by Jakub Ś

Attachment: 8887.patch added

comment:5 Changed 6 years ago by Jakub Ś

Keywords: Firefox Webkit added
Status: assignedreview

This tiny change proposed by @insad fixed one pixel issue in Webkit and Firefox.

There is still a problem in IE6 but it is independent of this ticket. Reported here for IE6: #8907

comment:6 Changed 5 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.4
Status: reviewreview_passed

comment:7 Changed 5 years ago by Jakub Ś

Resolution: fixed
Status: review_passedclosed

Fixed with [7530].

comment:8 Changed 5 years ago by Wiktor Walc

Description: modified (diff)
Summary: Kawa skin: dialog.css errorKama skin: dialog.css error
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy