Opened 8 years ago

Closed 7 years ago

#8889 closed Bug (fixed)

SCAYT inserts nonbreaking spaces in IE 9/8/7 and Chrome 18

Reported by: Brad Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.0
Keywords: IE Webkit Cc:

Description

Operating System: Windows

Browser(s) Tested: IE 9/8/7, Chrome 18

Full Notes: Using SpellCheckAsYouType inserts non-breaking spaces into content instead of regular spaces. This seems to happen nearby a word that has been flagged as invalid. It does not happen when SCAYT is turned off. It also does not seem to happen with pasting content.

While not ideal, it does not seem affect the main content area very much. However, the sidebars are more problematic because two medium sized words combined together are likely to force strange word wraps or content to overflow the provided area.

NOTE: This bug is reproduceable on the CKEditor demo

Steps to Recreate:

  1. Use CKEditor demo in IE 7/8/9 or Chrome and turn on SCAYT
  2. Type the following with 1   at the end of this string: good baaaaad baaaadd goood
  3. Click the Source view and observe   at the end
  4. Click back to regular view and put your cursor at the end of the string and backspace to remove it
  5. Click the Source view again, notice the   is removed
  6. Click back to regular view again and put your cursor right in front of "goood" then backspace once to connect to the last misspelled "bad" word
  7. Go to Source and notice no  
  8. Go to regular and put the cursor back in between the 2nd "bad" word and "goood" and delete the rest of the connected "bad" word
  9. Go to Source and notice  

Attachments (2)

a.png (23.9 KB) - added by David 8 years ago.
A series of "a"s with spaces in between
a-error.png (22.1 KB) - added by David 8 years ago.
A series of "a"s with spaces and nonbreaking spaces when looking at the HTML

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by Brad

Please disregard the second paragraph (starting with "While not ideal") as it is specific to our usage of CKEditor. I couldn't figure out how to remove it shortly after posting the ticket.

Changed 8 years ago by David

Attachment: a.png added

A series of "a"s with spaces in between

Changed 8 years ago by David

Attachment: a-error.png added

A series of "a"s with spaces and nonbreaking spaces when looking at the HTML

comment:2 Changed 8 years ago by David

Here's another example case. I've attached two images "a.png" and "a-error.png" illustrating the result of the steps below:

  1. Go to ckeditor.com/demo in IE 9, 8, or 7
  2. Enable SCAYT
  3. Type the following at a moderate rhythm "a a a a a a a a a a a a a a a"
  4. Click "Source" and note any   code.

This can also be recreated with by typing any long body of text. I'm using IE 9.0.8112.16421

comment:3 Changed 8 years ago by Jakub Ś

Keywords: IE Webkit added
Status: newconfirmed
Version: 3.6.3 (SVN - trunk)3.0

This issue has been reproducible in Webkit and IE6-9.

Webkit from CKE 3.0

IE6-9 from CKE 3.4.3

NOTE: Especially in older versions of CKEditor in IE you have to wait after you make space at the end for the word to get underlined. Space at the end will not be added otherwise.

comment:4 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I was not able to reproduce this problem anymore.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy