Ticket #8952 (closed Bug: expired)

Opened 2 years ago

Last modified 21 months ago

getData() does not work properly for specific instances of CKEditor

Reported by: evrim Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi,

I have a problem with CKeditor instance.getData() method. It is apparently due to random instance id's. Ok here's the plot:

1.Create an instance with random-id1. (No instance is created before w/ this id) 2.getData() runs properly 3.Destroy the instance (instance.destroy(); or instance.destroy(true); ) 4.Create another instance with the same random Id.

  1. Now, try getData() and it will never return the updated version.

This is the proper redefinition of my bug #8585. I've just figured out how to solve i'm resubmitting.

I'm on 7339 nightly build.

Thank you, evrim.

Change History

comment:1 Changed 23 months ago by j.swiderski

  • Status changed from new to pending
  • Keywords getData removed

Hi sorry for the late reply.

@evrim could you provide a sample file showing this problem because I was not able to reproduce it?

comment:2 Changed 21 months ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy