Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#8961 closed Bug (fixed)

Inline styles are not applied to beginning text in IE 9

Reported by: jessicab Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.4
Keywords: IE9 Cc:

Description

I an unable to apply inline styles to text at the beginning of a CKEditor when using IE9 in Windows 7. It seems to work fine in older versions of IE and in Firefox.

To recreate this go to the demo page http://nightly.ckeditor.com/7484/_samples/replacebyclass.html. If you highlight "This is" and try to apply the "Marker: yellow" from the styles drop down box, it won't apply the style. It seems to work if you are not selecting the first character in the CKEditor box.

Change History (6)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE9 added
Status: newconfirmed
Version: 3.6.4 (SVN - trunk)

Reproducible from CKEditor 3.6.4 rev. [7479] in IE9 only.

comment:2 Changed 5 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

Expired on trunk.

comment:3 Changed 5 years ago by jessicab

This is not actually fixed as of the newest nightly build Revision number: 7568. I wasn't sure what you mean by "expired on trunk". Is this something that just won't be fixed since IE will have newer versions?

comment:4 Changed 5 years ago by Jakub Ś

I have just tried this TC one more time and it worked. I have selected "This is", applied "Marker Yellow" style and it got applied in IE9.

Could you tell us how to make it not work? Could you perhaps provide screen cast?
Have you refreshed the cache before checking this TC?

comment:5 Changed 5 years ago by Jakub Ś

Ok I have managed to reproduce this problem - with one line it sometimes works and sometimes not but if you add second line you should be able to reproduce this problem always.

All in all it turned out that this is a dup of #9097. TC is the same you have to start selection a little bit to the left of text.

comment:6 Changed 5 years ago by Jakub Ś

The rev. mentioned in this ticket is invalid as I didn't know the key to reproduce the problem - you have to start selection a little bit to the left of text.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy