Opened 6 years ago

Closed 5 years ago

#8971 closed Bug (fixed)

IE 7 & IE 8&9 Compat View: Image dialog gets huge, if image has Large Alternate text

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.4
Component: UI : Dialogs Version: 3.0.2
Keywords: IE IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. Open any CK Editor sample & open Image Properties dialog.
  1. Insert an URL for the image and enter some Alternate text which as at least 250 words
  1. Click your mouse on the dialog & drag the dialog to the end of the screen.

Issue: Image Properties dialog gets huge and it expands to the size of the screen

Th dialog looks huge even when we close it bring it up again. we have to close and re-open the editor to get the dialog to normal size. Reproduced in IE7, IE8 & IE9 Compat view

Attachments (3)

test.txt (1.3 KB) - added by Jakub Ś 6 years ago.
8971.patch (518 bytes) - added by Frederico Caldeira Knabben 5 years ago.
8971_2.patch (4.2 KB) - added by Garry Yao 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by Jakub Ś

Attachment: test.txt added

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: 3.0.2
  1. To reproduce use the below tag on page:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

  1. Copy contents from test.txt
  2. Open image dialog, paste the text in "Alternative text" filed
  3. Start moving the dialog. I got the best results when moving dialog to the left viewport border.

Problem has been reproducible from CKEditor 3.0.2.

NOTE: Issue can be also reproduced in IE8 and IE9 when using Tools -> Compatibility View Settings

comment:2 Changed 6 years ago by Damian

Is there any update to this ticket? I'm looking for a patch at the moment.

comment:3 in reply to:  1 Changed 6 years ago by Frederico Caldeira Knabben

Replying to j.swiderski:

Your TC is confirmed with IE9+Compat as well. No need of special configurations.

That's clearly an IE issue. Let's hope a workaround can be easily found.

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

Basically, it looks like we need to enforce a fixed width for the field on IE8-.

Changed 5 years ago by Frederico Caldeira Knabben

Attachment: 8971.patch added

Changed 5 years ago by Garry Yao

Attachment: 8971_2.patch added

comment:5 Changed 5 years ago by Garry Yao

Status: reviewreview_failed

8971.patch is not a solution but rather a hack.

comment:6 Changed 5 years ago by Garry Yao

Component: GeneralUI : Dialogs
Milestone: CKEditor 3.6.4
Owner: changed from Frederico Caldeira Knabben to Garry Yao
Status: review_failedreview

It looks like the bug can be workaround with a absolute positioned input element.

comment:7 Changed 5 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

So we're in a hack competition at this point :) I just wanted to be less risky :P

Anyway, your patch looks good. What a browser bug like this could ask for? ;)

comment:8 Changed 5 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [7512].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy