Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#8988 closed Bug (wontfix)

with JAWS: Focus not shown when you navigate menu options

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone:
Component: Accessibility Version: 3.4
Keywords: IBM VendorFix Cc: damo, tmonahan

Description (last modified by j.swiderski)

To reproduce the defect:

  1. with JAWS on, Open any CK Editor sample, navigate to editor body.
  1. Press Alt+F10 to access the toolbar.
  1. Navigate to Spell Check As You Type button menu.
  1. Press Enter/Space to activate menu
  1. Navigate through the options using Arrow keys.

Issue: Focus not shown when we navigate through the options

It's because JAWS switching to Virtual PC Cursor when we open the menu, JAWS should stay in Forms mode when we are navigating through menu options.

This is a High Priority Accessibility defect for our Customer and needs to be fixed.

Attachments (2)

2012-07-05_0916.swf (671.5 KB) - added by j.swiderski 3 years ago.
Firefox
2012-07-05_0920.swf (567.5 KB) - added by j.swiderski 3 years ago.
IE8

Download all attachments as: .zip

Change History (13)

comment:1 Changed 3 years ago by j.swiderski

  • Component changed from General to Accessibility
  • Description modified (diff)
  • Status changed from new to confirmed
  • Version set to 3.4

This particular TC can be reproduced from CKEditor 3.4. Before this version either menu didn't show up or menu options were not read at all.

I’ve checked it with JAWS 13.0.852.

comment:2 Changed 3 years ago by garry.yao

  • Milestone set to CKEditor 3.6.4
  • Owner set to garry.yao
  • Status changed from confirmed to assigned

comment:3 Changed 3 years ago by garry.yao

  • Status changed from assigned to pending

WFM with JAWS 13 on both Fx/IE, the dropdown list of the button menu work as it in context menu.

comment:4 Changed 3 years ago by damo

I can still reproduce on nightly using both FF ESR 10.0.4 and FF 13.0.1, with JAWS 13.0.924.

comment:5 Changed 3 years ago by j.swiderski

  • Status changed from pending to confirmed

I was also able to reproduce it on IE and FF.

To reproduce:

  1. Turn on JAWS
  2. Tab (or click in) to CKEditor content area
  3. Press Alt+F10
  4. Tab to Scayt bar
  5. Press Space and then down arrow - Options will be read but not highlighted

NOTE: If you press space two times and then down arrow you will see focus on options.

Changed 3 years ago by j.swiderski

Firefox

Changed 3 years ago by j.swiderski

IE8

comment:6 Changed 3 years ago by j.swiderski

Tested on windows XP.

In IE I had to clear cache first as this TC seemed to work the second time I've tried it.

comment:7 Changed 3 years ago by fredck

  • Keywords VendorFix added
  • Milestone CKEditor 3.6.4 deleted
  • Resolution set to wontfix
  • Status changed from confirmed to closed

Our focus on accessibility support is FF Latest + Windows 7 + JAWS Latest. In this setup this issue is not reproducible.

In our tests, the only variable we introduced is the operating system. It looks like JAWS has issues with Windows XP.

Other than the fact that we're not able to workaround it, we're talking about a JAWS issue on a specific OS, so we need to have this fixed at the FS side.

comment:8 Changed 3 years ago by damo

As per comment 4, I am still able to reproduce this on Windows 7 with the latest FF and latest JAWS, therefore this is not OS specific.

JAWS should switch to forms mode when focusing on a menu container. As j.swiderski has mentioned, this does sometimes work, so the issue is at least intermittent, but seems to always manifest the first time. I have also seen it work intermittently.

I have tested the same configuration (Win 7, FF, JAWS) using other WAI-ARIA menu implementations e.g. http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/test_Menu.html and have not been able to reproduce the intermittent problem that I am getting with the editor.

We will raise this issue with FS, however, until we get a confirmation that this is a JAWS bug, I would ask that you leave this ticket open.

comment:9 Changed 3 years ago by garry.yao

@damo, would u provide a screencast illustrating the witness of it on Win7? And how does the prompting sound (beep) behave for you while focus is moved to the toolbar, and to the menu, correspondingly?

comment:10 Changed 3 years ago by garry.yao

Ok Damian, I confirmed it with J13.0.924, while it looks like J13.0.718 works well in this sense, and it seems we're doing good with the ARIA markups, so would be worth checking if it's a JAWS regression from the FS side.

comment:11 Changed 3 years ago by tmonahan

This seems to be fixed with Jaws 14. We have tested it against CKEditor 4.0 with JAWS 14 on FF 16.0.1 in Windows XP and focus is clearly shown as we navigate through the options.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy