Opened 5 years ago

Closed 5 years ago

#9094 closed Bug (fixed)

Flash content not inserted properly from rev 7542

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone: CKEditor 3.6.4
Component: General Version: 3.6.4
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. Open Ajax sample, open Flash dialog
  1. Enter the following URL http://bytescout.com/files/demo/swfscout_VideoSample.swf & click OK
  1. Remove the Editor.

Issue: Flash not shown in Editor body.

This works on nightly build but broken from rev 7542

HTML Source for flash inserted on nightly build which is using rev 7538

<p>
	<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"><param name="quality" value="high" /><param name="movie" value="http://bytescout.com/files/demo/swfscout_VideoSample.swf" /><embed pluginspage="http://www.macromedia.com/go/getflashplayer" quality="high" src="http://bytescout.com/files/demo/swfscout_VideoSample.swf" type="application/x-shockwave-flash"></embed></object></p>

HTML Source for flash inserted on build which is using rev 7542

<p>
	<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"></object></p>

Attachments (1)

9094.patch (2.1 KB) - added by Alfonso Martínez de Lizarrondo 5 years ago.
patch draft

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.4

Changed 5 years ago by Alfonso Martínez de Lizarrondo

Attachment: 9094.patch added

patch draft

comment:2 Changed 5 years ago by Alfonso Martínez de Lizarrondo

The problem seems to be that now the object and embed aren't being treated as unknown (previously they were checked as "cke:object" and now as "object") but the code in fragment.js doesn't have the same protection.

The patch is just a quick test, someone else should write it properly.

comment:3 Changed 5 years ago by Jakub Ś

Status: newconfirmed

Reproducible from rev. [7542]

comment:4 Changed 5 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

I've partial reverted [7542], which is proven to break the parsing of custom elements, the idea is that any custom element would be parsed with no DTD check, eventually allow us to create HTML structure that are not good in scheme but good for DOM (in this case, the object embed hack).

Additional, a fix is done to remove the "cke-real-element-type" being incorrectly used for tag name, which is supposed to be used for presentation purpose only.

Fixed with [7545].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy