Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9127 closed Bug (fixed)

IE6-8 selection range lost when pasting with dialog — at Version 7

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.4
Keywords: Cc:

Description (last modified by Jakub Ś)

I have found it when checking #8849.

To reproduce:

  1. Load the "replacebyclass" sample;
  2. Select first line and copy/paste it. You should have 7 lines.
  3. Select the bold text "sample text" in third line from the bottom;
  4. Press Tab key to move focus outside of editor;
  5. Click on "Paste" toolbar button, choose to deny clipboard access in order to bring up dialog.
  6. Fill in the dialog with some text "abc" then click on Ok

Result: Selection is applied to wrong text.

  1. This particular issue has been reproducible from rev. [7518]

NOTE:

Before this rev. [7518], the above TC produced JS error: Message: Invalid argument.
Line: 802
URI: /ckeditor/_source/plugins/selection/plugin.js
It has been reproducible from rev. [7239] to [7382]; got fixed in [7383] and showed up again from [7447] to [7517]; got fixed in [7518] (which resulted in wrong selection described in that ticket).

Change History (7)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

#9116 is also broken by [7518]

comment:2 Changed 7 years ago by Garry Yao

I cannot confirm it, can we have a reduced tc for that?

comment:3 Changed 7 years ago by Wiktor Walc

I can't reproduce it either. In IE6 "sample text" is replaced with "abc".

comment:4 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: confirmedclosed

Fixed after #9116 get closed.

comment:5 Changed 7 years ago by Jakub Ś

Result one got fixed but you have come back to result 2. Please check #9132 for more details.

NOTE: Please use CRTL+F5 or clear cache from time to time if you have problems with reproducing.

comment:6 Changed 7 years ago by Jakub Ś

Description: modified (diff)

comment:7 Changed 7 years ago by Jakub Ś

Description: modified (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy