Opened 7 years ago

Closed 6 years ago

#9168 closed Bug (fixed)

Chrome and FF ; When a new page that using docprops plugin, title is not set.

Reported by: fujikawa.naoki Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.4
Keywords: Cc:

Description (last modified by Jakub Ś)

Using the Chrome and IE, was discovered in version 3.6.5. Does not occur in IE.

  1. open _samples/fullpage.html
  2. click new page button
  3. click Document Properties(open dialog)
  4. "test" is inputted into the text area of a page title.
  5. click ok button
  6. click source button

result

<html>
	<head>
		<title></title>
	</head>
	<body></body>
</html>

The same result was brought also by http://nightly.ckeditor.com/7582/_samples/fullpage.html. 6)click source /or a submitt button is also the same.

Attachments (1)

9168.patch (1.0 KB) - added by fujikawa.naoki 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed
Version: 3.6.4

Reproducible in Firefox, Webkit and Opera (works in IE browsers) from CKEditor 3.6.4 rev. [7499].

comment:2 Changed 7 years ago by Jakub Ś

Description: modified (diff)

comment:3 Changed 7 years ago by Jakub Ś

If you use New Page command or remove sample title (available from rev. [7564]) in Source, switch to WYSIWYG and then try to insert new title with docProps dialog, this will not work.

On the other hand editing existing page title or using CARL+A and Backspace/Delete pressed couple of times to clean the page and then inserting new title with docProps works without problems.

comment:4 Changed 7 years ago by fujikawa.naoki

I'm sorry. Mistake the form below.

Was confirmed by nightly build(7609), did not occur. Thank you.

Last edited 7 years ago by fujikawa.naoki (previous) (diff)

Changed 7 years ago by fujikawa.naoki

Attachment: 9168.patch added

comment:5 Changed 7 years ago by fujikawa.naoki

I've uploaded a bugfix patch.

I wonder if this fix can be confirmed.

Last edited 7 years ago by fujikawa.naoki (previous) (diff)

comment:6 Changed 7 years ago by Jakub Ś

Since this is recent regression it should be fixed with next release (if possible). Patch for this bug will be checked and we will either apply this one or provide new one.

It all depends on tests.

comment:7 Changed 7 years ago by Olek Nowodziński

This issue has been fixed in v4: #9882.

comment:8 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy