Opened 6 years ago

Closed 6 years ago

#9882 closed Bug (fixed)

Docprops - title isn't set

Reported by: Piotrek Koszuliński Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.0.2
Component: General Version: 4.0 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

  1. Open docprops sample.
  2. Open docprops dialog.
  3. Enter a title and press ok.
  4. Switch to source mode - there's no title.
  5. Switch back to wysiwyg mode.
  6. Open docprops dialog - there's no title.

Everything works fine if at first title is set in source mode.

Confirmed on FF and Chrome. Similar ticket: #9168.

Change History (6)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 4.04.0 Beta

This can be reproduced from CKE 4 beta in Webkit, Firefox and Opera. Works fine in IE.

comment:3 Changed 6 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:4 Changed 6 years ago by Olek Nowodziński

Status: assignedreview

Crated t/9882@cksource branch with a fix.

In fact the problem wasn't the docprops plugin but dataprocessor. In all browsers but IE, empty <title> tag contains no children (text nodes). This is why 'data-cke-title' isn't copied into <title> tag: there's no node for such data to be copied.

The solution is basically to create such text node if there's no any. I didn't restrict this solution to !CKEDITOR.env.ie since future versions may not insert this empty node. We can eventually change this.


Additionally crated t/9882@tests-v4 branch with basic dts for title setting and reading via docprops dialog.

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

This one fixed #9168 as well.

comment:6 Changed 6 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Fixed with git:cd289c2 on dev and ebe59d9 on tests-v4.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy