Opened 7 years ago

Closed 7 years ago

#9234 closed Bug (fixed)

[IE7,8] Magicline leaks out of an inline editor

Reported by: Olek Nowodziński Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: Cc:

Description

  1. Open http://ckeditor4.t/ckeditor/samples/inlinebycode.html
  2. Follow the attached video.
  • Can be reproduced in either IE7 or 8.

Attachments (3)

ie7MagiclineLeak.ogv (1.5 MB) - added by Olek Nowodziński 7 years ago.
ie78_ceditable_mousemove_bug.html (1.4 KB) - added by Olek Nowodziński 7 years ago.
mlIeLeaks.png (93.5 KB) - added by Olek Nowodziński 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by Olek Nowodziński

Status: newassigned

Changed 7 years ago by Olek Nowodziński

Attachment: ie7MagiclineLeak.ogv added

comment:2 Changed 7 years ago by Olek Nowodziński

Summary: [IE] Magicline leaks out of an inline editor[IE7,8] Magicline leaks out of an inline editor

Created dev branch t/9234. This issue can be considered only after #9251 is resolved.

The problem is caused by buggy mousemove listener in IE7(8) (see attached html file for further instructions).

Changed 7 years ago by Olek Nowodziński

comment:3 Changed 7 years ago by Olek Nowodziński

Status: assignedreview

comment:4 Changed 7 years ago by Piotrek Koszuliński

I'm not able to reproduce this bug after #9251 has been masterised.

comment:5 in reply to:  4 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: reviewclosed

Replying to Reinmar:

I'm not able to reproduce this bug after #9251 has been masterised.

Please close the ticket in those cases.

Changed 7 years ago by Olek Nowodziński

Attachment: mlIeLeaks.png added

comment:6 Changed 7 years ago by Olek Nowodziński

Resolution: worksforme
Status: closedreopened

The problem is reproducible and definitely not yet resolved. The magicline is still leaking in IE7/8 (see: mlIeLeaks.png)

comment:7 Changed 7 years ago by Olek Nowodziński

Status: reopenedreview

comment:8 Changed 7 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I can't reproduce this. Really :) But if you're sure and you found a bug in ML code, then go ahead and masterise this fix. However, it'd good if someone else could confirm this issue :).

comment:9 Changed 7 years ago by Piotrek Koszuliński

Wow... That's weird. Just after I've again written that I can't reproduce the issue, I reproduced it for the first time :).

comment:10 Changed 7 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Fixed and masterized with this commit

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy