Opened 7 years ago

Closed 7 years ago

#9235 closed Bug (worksforme)

[Opera] Various magicline issues

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: Cc:

Description

  1. Open replacebyclass sample.
  2. Ctrl+a, delete to delete editor's content.
  3. Insert table.
  4. Magicline above the table sometimes is sometimes isn't displayed.
  5. Place caret in paragraph that should remain under the table.
  6. Press delete, cursor is moved to table, now there are no paragraphs under the table.
  7. Try to evoke magicline under the table. I wasn't able.
  8. Sometimes when 7. is possible at the beginning of this scenario (because there's no paragraph under the table after inserting table), then creating new paragraph with magicline and deleting it gives the same result - 7. becomes an issue.

Attachments (1)

2012-09-14_1820.swf (805.9 KB) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by Olek Nowodziński

Status: newpending

I can't reproduce it on master. My concerns about it are as follows:

  • Most likely it has been fixed by #9251 changes.
  • It has been fixed by some other focus-related ticket, as Opera has problems with it and magicline is highly dependent on focus.

comment:2 Changed 7 years ago by Jakub Ś

Status: pendingconfirmed

I'm not sure if this is what you were having but here goes:

  1. Open magic line sample in Opera
  2. Click new page to delete all contents
  3. Insert table or div container
  4. Hover over the table to see magic line
  5. Click on dashed line

Result: magic line no longer works.

Please see also screen cast.

Changed 7 years ago by Jakub Ś

Attachment: 2012-09-14_1820.swf added

comment:3 Changed 7 years ago by Olek Nowodziński

Status: confirmednew

Thanks for your feedback. Unfortunately this is not a magicline issue. The focusmanager is buggy in Opera.

Too see this, go to http://ckeditor4.t/ckeditor/samples/api.html (official API sample) and reproduce your steps (screencast) watching the status line ("editor1 is focused", "editor1 lost focus", ...). Then you'll find out that editor loses focus in Opera and it's gone for good. Focus is required by the magicline to run.

I guess that it's strongly correlated with #9224 and it will be fine when the ticked is done.

comment:4 Changed 7 years ago by Olek Nowodziński

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy