Opened 7 years ago

Closed 7 years ago

#9236 closed Bug (duplicate)

[FF36] Entire inline editable may be selected from inside

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Cc:

Description

  1. Open any inline sample.
  2. Focus editor.
  3. Press ctrl+a.
  4. Press ctrl+c.
  5. Paste copied content.

See that Firefox copied entire editable element, which pasted does a lot of mess.

Change History (3)

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0

comment:2 Changed 7 years ago by Jakub Ś

Status: newconfirmed

Latest trunk in Firefox 3.6:

  1. Inline element sample - New content gets pasted for 1 second next to old content. It then disappears but old content now takes half the available space. It happes because one editing div gets pasted into the second div.
  1. Inlineall - executing above TC results in new content being pasted for 1 second below all content which then disappears. Paddings also increase because one editing div gets pasted into second div.

Because of these nested divs when you click outside of edited area toolbar disappears but it is still possible to type (area is grey).

comment:3 Changed 7 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: confirmedclosed

This issue was reported earlier than #9534, but it was FF36-only ticket at that time. Now I can reproduce the same on all browsers, so let's close this and leave #9534, especially that it was already accepted for 4.0.

PS. Delays (which are <<<1s) when pasting content on FF36 are a separate issue and if I remember correctly - "wontfix".

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy