Opened 7 years ago

Closed 7 years ago

#9240 closed Bug (fixed)

Arrows not rendering correctly on menus in high contrast mode

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

To reproduce:

  • Switch to high contrast mode.
  • Open any CKEditor sample and insert a table.
  • Right click to view the context menu.

Problem: The right arrow for sub menus is not displaying properly. Instead the unicode value is displayed.

This is due to a missing # in the unicode value.

Line 407 in menu/plugin.js is currently:

var arrowLabel = '&' + ( this.editor.lang.dir == 'rtl' ? '9668' : '9658' ) + ';';

It should be:

var arrowLabel = '&#' + ( this.editor.lang.dir == 'rtl' ? '9668' : '9658' ) + ';';

Change History (1)

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Thanks for the fix, tmonahan. Fixed with a1d5c4e.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy