Opened 10 years ago

Closed 10 years ago

#9260 closed Bug (fixed)

Combo boxes should not react on hover in read-only mode

Reported by: Piotrek Koszuliński Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: Cc:

Description

Regression after v3.

Change History (5)

comment:1 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newreview

Rich combo should adapt to the new state-ful button styling rules:

cke_combo_button_off{ ...styles for normal combo...}
cke_combo_button_on{ ...styles for opened combo...}
cke_combo_button_disabled{ ...styles for disabled combo...}
cke_combo_button_off:hover{ ...styles for normal combo, when hovered...}

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

The way it is done now is correct, applying the status of the combo to the outer element. In this way, other parts of the combo widget can be touched by the status, like the label.

It looks like this fix requires a CSS fix only.

comment:3 Changed 10 years ago by Garry Yao

Status: review_failedreview

Ok, I've moved up the combo state onto the top element.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:5 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy