Opened 10 years ago

Closed 10 years ago

#9288 closed Bug (duplicate)

TypeError: this.getWindow().$.getComputedStyle(this.$, "") is null

Reported by: Jay Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: Cc:

Description

Using CKEditor along with CKFinder within a page which is loaded dynamically via jQuery / Ajax.

Immediately upon page load I get the error TypeError: this.getWindow().$.getComputedStyle(this.$, "") is null

The page renders correctly along with the CKEditor interface.

However when I click on the Images icon to upload an image I notice the CKFinder tab for 'Upload' is missing. There is also no ability to browse the server for an image.

What sayeth the group ?

Jay CompuMatter

Attachments (2)

this-getWindow.png (214.6 KB) - added by Jay 10 years ago.
On Page Load
nockeditor.png (145.2 KB) - added by Jay 10 years ago.
Missing ckeditor ui

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by Jay

Attachment: this-getWindow.png added

On Page Load

Changed 10 years ago by Jay

Attachment: nockeditor.png added

Missing ckeditor ui

comment:1 Changed 10 years ago by Jay

CKEditor and CKFinder work find and predictably when used in the same page but called without Ajax / jQuery UI. However, as Ajax / jQuery file, it spawns that getWindow error.

Firefox 15.0 and Chrome and IE8 Windows Vista 64

Of possible value: Everything behaves normally when loading as a standard (non-ajax) page. It is only when I load this page via ajax that the error and missing ckfinder are an issue.

Here is a video of problem as it happens : http://youtu.be/PWQwx-0EcvA

Please note the UI I am using is inside a jQuery UI Dialog Window and then inside jQuery UI Tabs. The problem DOES NOT appear when using jQuery UI Dialog but without jQuery UI Tabs

Last edited 10 years ago by Jay (previous) (diff)

comment:2 Changed 10 years ago by Jay

Last edited 10 years ago by Jay (previous) (diff)

comment:3 Changed 10 years ago by Jay

Last edited 10 years ago by Jay (previous) (diff)

comment:4 Changed 10 years ago by Jakub Ś

Could we ask you to provide reduced and working test-case file(s) that show a problem in code.

If we had code that you are having problems with, it would be easier for us to determine what is wrong.

comment:5 Changed 10 years ago by Jakub Ś

Keywords: ckfinder getComputedStyle removed
Status: newpending

@compumatter any chance for providing this reduced test case?

Have you managed to solve your problem or it still occurs?

comment:6 Changed 10 years ago by Wiktor Walc

Resolution: duplicate
Status: pendingclosed

Duplicate of #8578

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy