Opened 7 years ago

Closed 5 years ago

#9332 closed Bug (duplicate)

FF:IME is disabled if startupFocus is true.

Reported by: fujikawa.naoki Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox, IBM Cc: lynne_kues@…

Description

IME(use Japanese input methods) is disabled if startupFocus is true.

By v3.6.4 and v3.6.3, it checked using FF. In Chrome or IE, IME is enabled.

It can be used, if a focus is removed once and it returns from wysiwyg area.

Attachments (5)

FF.html (689 bytes) - added by fujikawa.naoki 7 years ago.
It is checked html.
2012-09-21_1621.swf (939.2 KB) - added by Jakub Ś 7 years ago.
_child.html (580 bytes) - added by Jakub Ś 7 years ago.
_parent.html (419 bytes) - added by Jakub Ś 7 years ago.
_child.2.html (580 bytes) - added by Jakub Ś 7 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by fujikawa.naoki

Attachment: FF.html added

It is checked html.

Changed 7 years ago by Jakub Ś

Attachment: 2012-09-21_1621.swf added

Changed 7 years ago by Jakub Ś

Attachment: _child.html added

Changed 7 years ago by Jakub Ś

Attachment: _parent.html added

Changed 7 years ago by Jakub Ś

Attachment: _child.2.html added

comment:1 Changed 7 years ago by Jakub Ś

Keywords: Firefox added
Status: newconfirmed
Version: 3.0

Please see the attached screencast showing what the problem is.

  • I have set Japanese language and Hiragana Input mode while having focus in editor.
  • I have reloaded the page and input method has changed to half-width Alphanumeric
  • I had to click outside editor and in editor again to activate Hiragana.

I have tried with plain iframe and there seem to be no problem which made me think there is some focus error in CKEditor that prevents IME from activating correct IME state.

Problem has been reproducible in Firefox from CKEditor 3.0.

comment:2 Changed 7 years ago by Lynne Kues

Cc: lynne_kues@… added
Keywords: IBM added

comment:3 Changed 6 years ago by Jakub Ś

This issue and #9749 concern same problem.

comment:4 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

I'm closing this one as duplicate of #9749.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy