Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#9749 closed Bug (wontfix)

Cannot type Japanese Characters into the editor

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.4
Keywords: IBM HasPatch Cc: Damian, Satya Minnekanti, lynne_kues@…

Description

  • Configure your computer so that a Japanese keyboard is available. (See attached document for further information on how to do this).
  • Open the attached HTML sample in Firefox with the Japanese keyboard enabled and type in the editor.

Problem: The text is entered into the editor in English and it is not possible to switch the input mode to Japanese.

This is reproducible in 3.6.4 and 3.6.5 but works correctly in 3.6.3 and 4.0. It only seems to occur when startupFocus: true is included in the editor config. We have reproduced this on both FF10 ESR and FF16.

Attachments (3)

Setting up keyboard in Japanese.doc (420.0 KB) - added by Teresa Monahan 7 years ago.
Problem Typing Japanese.html (1.3 KB) - added by Teresa Monahan 7 years ago.
9749.patch (1.8 KB) - added by Wiktor Walc 7 years ago.

Download all attachments as: .zip

Change History (15)

Changed 7 years ago by Teresa Monahan

Changed 7 years ago by Teresa Monahan

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Status: newconfirmed

This issues appeared on 3.6.4 because of the fixes promoted for #8925 and #9096, where we basically removed a hack made for issues with old Firefox versions, which was not any more necessary.

In this ticket instead, we're hitting yet another Firefox bug. We're now in a situation where we can't revert that change otherwise we'll have those issues regressing.

The current workaround is clicking outside the editor and back to it again. I'll report this issue to Mozilla soon.

comment:2 in reply to:  1 Changed 7 years ago by Teresa Monahan

Replying to fredck:

The current workaround is clicking outside the editor and back to it again. I'll report this issue to Mozilla soon.

Can you please add a link to the Mozilla defect for this? Thanks

comment:3 Changed 7 years ago by Lynne Kues

Cc: lynne_kues@… added

comment:4 Changed 7 years ago by Lynne Kues

This has become a high priority, customer-related defect for us. Could you please provide more information about the Mozilla defect that is now impeding the proper activation of IME?

comment:5 Changed 7 years ago by Lynne Kues

Also, could you provide information about the hack you mention in comment 2?

comment:6 Changed 7 years ago by Wiktor Walc

I have filled a bug in Mozilla bug tracker: https://bugzilla.mozilla.org/show_bug.cgi?id=836231

Also I managed to simplify a bit the TC to the following HTML sample, where CKEditor is not used: simplified_tc.html (though it might not be exactly reflect the things that CKEditor is internally doing, at least it shows that something is wrong in FF)

Bringing back blinkCursor() trick would result again in #8925.

Changed 7 years ago by Wiktor Walc

Attachment: 9749.patch added

comment:7 Changed 7 years ago by Wiktor Walc

The attached patch reverts [7517] and [7546], in other words it brings back the blinkCursor() trick that was available till 3.6.3.

Note: #8925 will reappear after applying it

I removed the version check for gecko (CKEDITOR.env.version >= 10900) because we do not support FF 2.x anyway...

comment:8 Changed 7 years ago by Lynne Kues

Could you please supply patches for 3.6.4 and 3.6.6. Thanks.

comment:9 Changed 7 years ago by Wiktor Walc

Version: 3.6.53.6.4

Could you please supply patches for 3.6.4 and 3.6.6. Thanks.

I've checked the patch with 3.6.4 and 3.6.6 and was able to apply it cleanly without any problem

comment:10 Changed 6 years ago by Jakub Ś

This issue and #9332 concern same problem.

comment:11 Changed 5 years ago by Jakub Ś

Keywords: HasPatch added
Resolution: wontfix
Status: confirmedclosed

Since we don't provide fixed for past releases, patch is attached and this issue doesn't occur in CKEditor 4.x., I'm closing the ticket as "won't fix" and adding HasPatch keyword.

comment:12 Changed 4 years ago by Wiktor Walc

It looks like the problem in Firefox is gone (see https://bugzilla.mozilla.org/show_bug.cgi?id=836231).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy