Opened 7 years ago

Closed 7 years ago

#9359 closed Bug (fixed)

[IE, RTL] Dialog layout is broken under IE

Reported by: Olek Nowodziński Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.0
Component: UI : Dialogs Version: 4.0
Keywords: IE Cc:

Description

Tested in IE9.

Attachments (7)

dialogBrokenIeRtl.png (17.5 KB) - added by Olek Nowodziński 7 years ago.
IE7dialogRTLvsLTR.png (32.6 KB) - added by Olek Nowodziński 7 years ago.
IE8dialogRTLvsLTR.png (33.7 KB) - added by Olek Nowodziński 7 years ago.
IE9dialogRTLvsLTR.png (30.4 KB) - added by Olek Nowodziński 7 years ago.
bouncingButtonHover.gif (8.3 KB) - added by Olek Nowodziński 7 years ago.
9359_rtl_border-radius.png (1.4 KB) - added by Garry Yao 7 years ago.
IE9buttonCut.png (69.7 KB) - added by Olek Nowodziński 7 years ago.

Download all attachments as: .zip

Change History (16)

Changed 7 years ago by Olek Nowodziński

Attachment: dialogBrokenIeRtl.png added

comment:1 Changed 7 years ago by Garry Yao

Keywords: IE added
Owner: set to Garry Yao
Status: newassigned

comment:2 Changed 7 years ago by Garry Yao

Status: assignedreview

Opened t/9359 on dev for review, composed of two commits:

  1. Fixed RTL input field overflow in IE (v4 regression)
  2. Fixed RTL dialog button background in IE (v3 bug as well)

Changed 7 years ago by Olek Nowodziński

Attachment: IE7dialogRTLvsLTR.png added

Changed 7 years ago by Olek Nowodziński

Attachment: IE8dialogRTLvsLTR.png added

Changed 7 years ago by Olek Nowodziński

Attachment: IE9dialogRTLvsLTR.png added

Changed 7 years ago by Olek Nowodziński

Attachment: bouncingButtonHover.gif added

comment:3 Changed 7 years ago by Olek Nowodziński

Status: reviewreview_failed

I reviewed your changes. It's much better but unfortunately there's still a lot of work to do.


There's a number of things which are inconsistent in IE7+:


A cross-browser 1px issue on hover:

comment:4 Changed 7 years ago by Olek Nowodziński

Owner: changed from Garry Yao to Olek Nowodziński
Status: review_failedassigned

comment:5 Changed 7 years ago by Olek Nowodziński

Status: assignedreview

Updated t/9359 branch and rebased on the latest master.

From now on, dialog buttons (footer) should be consistent throughout supported browsers.

Changed 7 years ago by Garry Yao

Attachment: 9359_rtl_border-radius.png added

comment:6 Changed 7 years ago by Garry Yao

Status: reviewreview_failed

IE9 on RTL loose border-radius on button right side:

Changed 7 years ago by Olek Nowodziński

Attachment: IE9buttonCut.png added

comment:7 Changed 7 years ago by Olek Nowodziński

Status: review_failedreview

Sorry, but I cannot reproduce it:

comment:8 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

Sorry it may be caused by cache, WFM now.

comment:9 Changed 7 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Fixed and masterized.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy