Opened 7 years ago

Closed 6 years ago

#9360 closed Bug (fixed)

inline editing: Blocks shown for a div stay permanently even after user exists editing the div

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0.1
Component: General Version: 4.0
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. Open Massive inline editing sample
  1. Click on 3rd div & see that editor toolbar loads.
  1. Click on Show Blocks icon in the toolbar & see that blocks inside 3rd div or shown.
  1. Now click on 4th div.

Expected Result: Editor Toolbar loads for 4th div & Blocks shown for 3rd div should be removed.

Actual Result: Editor Toolbar loads for 4th div but Blocks shown for 3rd div still present..Same thing happens for all div's when we click on Show Blocks icon in the toolbar

Change History (6)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.1
Status: newconfirmed

comment:2 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

Opened review 01daec3

comment:3 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_failed

I again have on ticket branch two reds on IE9 - http://ckeditor4.t/dt/plugins/font/font.html

There are constantly green on master and constantly red on ticket branch. This is the same situation as in #9712. Weird, because these changes seem to be unrelated to font plugin.

Except that everything looks good.

comment:4 Changed 6 years ago by Garry Yao

Status: review_failedreview

I'm unable to confirm the test failures, can you check if it's caused by some other factors?

Last edited 6 years ago by Piotrek Koszuliński (previous) (diff)

comment:5 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

Today I'm unable too.

comment:6 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Masterised git:2e9da01.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy