Opened 7 years ago

Closed 7 years ago

#9362 closed Bug (fixed)

Table properties in context menu aren't shown immediately

Reported by: Olek Nowodziński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0
Component: UI : Context Menu Version: 4.0
Keywords: Cc:

Description

  1. Go to http://ckeditor4.t/ckeditor/samples/replacebyclass.html
  2. Right click the table

  1. Close the context menu. Right click the table again.

Attachments (3)

delayedTablePropsBefore.png (5.2 KB) - added by Olek Nowodziński 7 years ago.
delayedTablePropsAfter.png (8.0 KB) - added by Olek Nowodziński 7 years ago.
delayedProps.ogv (554.7 KB) - added by Olek Nowodziński 7 years ago.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by Olek Nowodziński

Attachment: delayedTablePropsBefore.png added

Changed 7 years ago by Olek Nowodziński

Attachment: delayedTablePropsAfter.png added

comment:1 Changed 7 years ago by Garry Yao

Status: newpending

WFM on both IE/Fx, any clue?

Changed 7 years ago by Olek Nowodziński

Attachment: delayedProps.ogv added

comment:2 Changed 7 years ago by Olek Nowodziński

Attached a screencast for this issue (Chrome).

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Status: pendingconfirmed

comment:4 Changed 7 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:5 Changed 7 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/9362@dev.

Issue occurs because selectionChange event on which commands are updated is fired after context menu is opened. My proposal is to force selection check before opening context menu.

comment:6 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

comment:7 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy