Opened 7 years ago

Closed 7 years ago

#9415 closed Bug (invalid)

Text selection is lost and doesn't get copied by right-clicking and selecting 'Copy' from context menu

Reported by: shashidhar Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.3
Keywords: Cc:

Description

Hi,

We are integrating CKEditor version 3.6.3. Because of few issues, we are using HTML 4.01 Frameset as the DOCTYPE for config.docType. When we use this DOCTYPE, everything is working fine except one issue mentioned below. Any help to overcome this issue is highly appreciated.

Steps to reproduce the issue:

  1. Double click to select one word. Word gets selected.
  2. Right click to open the context menu. Context menu gets opened.
  3. Select 'Copy' from context menu.

Expected: Selected word should be copied to clipboard and the word selection should still be there.

Actual: Selected word DOES NOT get copied to clipboard and the word selection is lost.

Browser: IE 8 and IE9

Note: 1) Though this issue does not happen every time but it happens very frequently. 8 out of 10 attempts will fail and only 2 times it will be fine. 2) Copy from the toolbar and keyboard shortcut works fine. 3) It also happens in the CKEditor samples if we use the above mentioned DOCTYPE

Attachments (2)

after_clicking_find_replace.jpg (40.0 KB) - added by shashidhar 7 years ago.
After clicking find/replace
before_clicking_find_replace.jpg (50.8 KB) - added by shashidhar 7 years ago.
Before clicking Find/Replace

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by Jakub Ś

Status: newpending

First of all you should update to latest CKEditor 3.6.4.

Second I have tried to set

config.docType = '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">';	

in config.js and then copy text with context menu.

The only thing I have noticed is that when context menu pops up in IE9, visible selection disappears but appears after choosing one of options.
Contents were in all cases copied to clipboard.
There were no problems in IE8.

Could you please provide more details, more exact step by step scenario to reproduce?
Is this reproducible in plain CKEditor or only in when editor is integrated in your application?

Changed 7 years ago by shashidhar

After clicking find/replace

Changed 7 years ago by shashidhar

Before clicking Find/Replace

comment:2 Changed 7 years ago by shashidhar

This issue does not happen after upgrading to 3.6.4 but i am facing another issue with 3.6.4 as mentioned here: When i Click on Find/Replace icon, backgroud screen becomes blank as shown in the screenshots. This happens only when editor is integrated to our application. Could you please let me know any suggestions you have.

FYI, In 3.6.3 samples, I have reproduced ticket #9415 using the folowing scenario

  1. Used the same docType as you mentioned.
  2. Opened the skins.html sample in IE9.
  3. Double click to select a word
  4. Right clik to get the context menu
  5. Select 'Copy' from the context menu.

After the fifth step, selection is lost and the word is not copied to the clipboard. As mentioned in my bug description, issue does not occur always but happens most of the times. This happens 6 to 8 out of 10 times.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

This happens only when editor is integrated to our application. Could you please let me know any suggestions you have.

There might be some CSS/style rule applied (E.g through your custom JavaScript) that changes opacity of background div.
Perhaps the background div gets replaced by some other element. You should check this (DOM) with IE9/or IE8 dev tools.

FYI, In 3.6.3 samples, I have reproduced ticket

Once again, the only thing I have noticed is that when context menu pops up in IE9, visible selection disappears but appears after choosing one of options. Contents were in all cases copied to clipboard.

Since this issue can't be reproduced in plain CKEditor I have to close it as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy