Opened 7 years ago

Closed 6 years ago

#9461 closed Bug (fixed)

[FF]: Inconsistent behavior in applying styling to selected text

Reported by: Lisa Curb Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox IBM Cc: monahant@…

Description

Steps to reproduce:

  1. Go to one of the demo pages (e.g., http://ckeditor.com/demo)
  2. Double click to select one of the words that does not have a style applied to it (I chose the word "famous" in the first line, but it really doesn't matter what you choose).
  3. Apply the Bold style to the text by either clicking the Bold button, or hitting Ctrl-B
  4. Now, with the text still selected, start typing (so that the selected text is replaced by the new text you are typing).

I expect to see the new text retain the bold styling, which is what I see in Chrome and IE 7, 8, and 9. However in Firefox, the Bold button is deselected, and the new text is not bolded.

Firefox version is 16.0.1, OS: Windows 7 Professional

Attachments (1)

style.png (33.6 KB) - added by Irina 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: Firefox added
Status: newconfirmed
Version: 3.6.53.0

I was able to reproduce it from CKEditor 3.0 in Firefox only.

Please note that this issue no longer occurs in CKEditor 4.x

There are however other issue with Firefox and CKE 4.x that still occur - #3509, #5026 (test 2), #8958.

comment:2 Changed 6 years ago by Teresa Monahan

Cc: monahant@… added
Keywords: IBM added

I can only reproduce this issue since changeset [6919]. Prior to this the new text entered in step 4 does correctly retain the selected styling.

Another usecase for this is:

  • Type some text
  • Select a word and apply a style e.g. Bold
  • Press the right arrow key to move to the end of the word.
  • Type some text.

Problem: The new text does not retain the styling in FF.

comment:3 Changed 6 years ago by Irina

Firefox 20, CKEditor version 4.x

  1. Type in some text
  1. Highlight one word and change it's style, e.g. font style, font size, bold, italic, etc
  1. Click back into the editor and continue typing after this word

Expected result: The style will be inherited

Actual result: The style changed back to default.

Changed 6 years ago by Irina

Attachment: style.png added

comment:4 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

@tmonahan and @irina original TC is no longer reproducible and both issues you describe are Firefox specific and depend how browser handles selection (IMHO they also have a little bit to do with #8195).

Please note that Elements Path shows exactly where you are. In Firefox when you apply style and then press right arrow you leave span while in other browsers you are still inside it. The same thing is with clicking - it all depends where you click - if Elements Path shows span, style will be continued.

I'm closing this issue as fixed. @tmonahan and @irina your issues are won’t fix.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy