Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9510 closed Bug (invalid)

IE8-10: New line is not created after inserting form in Enter_BR

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Cc:

Description

To reproduce:

  1. Open enterkey sample
  2. set enter mode to br and press New Page button
  3. Insert form using toolbar

Result: there is no new line below editor thus it is impossible to exit form element.

What is more magicline plugin doesn't work with forms - #9509, so there isn't any workaround but to add new line in source mode.

Change History (7)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

Note: it works in IE7 and modern browsers as expected.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

This is magicline's issue and editor is not intended to create new line after form by default.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: closedreopened

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: reopenedclosed

comment:5 Changed 6 years ago by Jakub Ś

@Reinmar what you are saying is - "there is no way to exit form in IE8-10".
This is not user friendly and IMO no solution.

The only workaround is switching to source and adding paragraphs there.

comment:6 Changed 6 years ago by Piotrek Koszuliński

After closing #9509 it will be possible to exit form in all browsers. In fact I'd say that other browsers' behaviour is incorrect - why do they create additional paragraph when I'm inserting form? Do you remember all those tickets regarding superfluous empty paragraph under the table? Magicline exists to get rid of it.

comment:7 Changed 6 years ago by Jakub Ś

I haven't understood your comment no. 2 and forgot about #8509. In this case everything is clear now. Solution is to make magicline work with forms. Thanks for clarifying that.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy