Opened 6 years ago

Closed 6 years ago

#9547 closed Bug (fixed)

Autogrow plugin breaks dropdowns

Reported by: florisb Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Mac Firefox Cc:

Description

When using the autogrow plugin in the latest build, dropdowns stop working. For example the font dropdown. As soon as you click it it disappears.

As soon as the editor has focus the dropdowns start working. But without focus the dropdowns don't work.

Check http://pxltest.nl/ckeditor4/samples/autogrow.html for an example.

This is tested in Firefox 16 on mac

Change History (10)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newpending

I was able to reproduce this issue once, but then... dropdowns constantly work as they should.

Are you sure that you can still reproduce this?

comment:2 Changed 6 years ago by florisb

Yes it keeps going wrong on firefox 16 on mac. In Chrome it does work.

comment:3 Changed 6 years ago by Jakub Ś

Keywords: autogrow dropdowns removed
Status: pendingconfirmed

Cheked under MAC 10.7 and FF 16.

  1. Open autogrow sample
  2. Click in editor, switch to source and paste below contents (taken from user link)
    <p>This is some <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>
    <p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p>
    <p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p><br />test</p>
    
  3. Click outside editor to lose focus.
  4. Click on dropdown

comment:4 Changed 6 years ago by Piotrek Koszuliński

Keywords: macosx added

This issue looks like MacOS only. We wasn't able to reproduce it on Win too.

comment:5 Changed 6 years ago by Jakub Ś

Keywords: Mac added; macosx removed

comment:6 Changed 6 years ago by Jakub Ś

Keywords: Firefox added

This problem can be reproduced in Firefox and v4 only (Regression when comparing to v3).

comment:7 Changed 6 years ago by RosemaryONeill

Is this bug going to be addressed? It's still happening with CK 4, FireFox 22, Windows (Vista Ultimate).

comment:8 Changed 6 years ago by Jakub Ś

Status: confirmedpending

@RosemaryONeill I have tried my TC steps from comment:3 in latest CKEditor 4.2 and wasn't able to reproduce this problem. Are you sure it is still happening?

Could you provide your TC steps and version of editor you use?

comment:9 Changed 6 years ago by RosemaryONeill

I can no longer reproduce the problem.

I removed autogrow and then put it back in and somehow the drop-downs started working.

I'm using version 4.2.

comment:10 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

I have checked this TC one more time and it seems to work. Problem has expired on master so I'm closing it as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy