Opened 7 years ago

Closed 7 years ago

#9571 closed Bug (fixed)

Drag & Drop in Firefox can destroy the editor

Reported by: Alfonso Martínez de Lizarrondo Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.0
Component: Core : Editable Version: 4.0
Keywords: Firefox Cc:

Description

Using the divarea or massive inline samples and Firefox:

Load the sample http://nightly-v4.ckeditor.com/3753/samples/divarea.html and select some text (selecting the picture doesn't work and it's really strange but I don't know if that's a new setting), and drop it in other place for example try to select "Red" and change from

Little Red Riding Hood

to Little Riding Hood Red

Result: Red moves to a new line with border... it turns out that the whole container div has been inserted inside the editor, switching to source and back to designs makes the "Red" block hide, although it's still there.

Similar problems happens with the massive inline sample http://nightly-v4.ckeditor.com/3753/samples/inlineall.html.

Other browsers seems to behave correctly

Change History (8)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Status: newconfirmed

Firefox clones entire editable when D&Ding. Unfortunately, since we don't handle D&D and it doesn't trigger paste, we're not able to handle this in decent way now. In fact, we'll have investigate if it's possible to handle this at all.

comment:2 Changed 7 years ago by Jakub Ś

Keywords: Firefox added

Problem can be reproduced in v4 and Firefox only

This clearly look like regression:

  1. In v3 In it is possible to drag and drop images
  2. In v3 we don't have inline and divarea sample.

To reproduce try in divarea sample to select red from Little Red Riding Hood and move it to get Little Riding Hood Red. You will get whole <span id="cke_editor1 pasted

Another way:

  1. In divarea sample presss CRTL+A, CRTL+C
  2. Go to inline all sample
  3. Click in one of editing areas and press CRTL+V

Result: you will get 12 <span id="cke_editor1

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

This is not a regression. v3 doesn't support divarea nor inline editing.

comment:4 Changed 7 years ago by Jakub Ś

Perhaps this part should be reported in separate ticket

In v3 In it is possible to drag and drop images

This is not possible even in iframe based dialog so this oiece is a regression.

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0
Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

I've pushed a fix for this on t/9571 on both cksource and tests.

This will fix the DnD issue. As for the image selection, I'll be opening a new ticket right now.

comment:6 Changed 7 years ago by Frederico Caldeira Knabben

#9584 has been opened for the image selection issue.

comment:7 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: review_passedclosed

Fixed with 41e6adc.

For the records, there is an issue with IE8 that throws an "Unknown Error" if we use <div> for the main structure. That was the reason for having chosen <span>, in fact.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy