Opened 6 years ago

Closed 6 years ago

#9624 closed Bug (fixed)

Unable to run builder with no plugins in profile

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: Project : CKBuilder Version: 4.0
Keywords: Cc:

Description

The following error occurs when running ckbuilder with no plugin entry:

Exception in thread "main" org.mozilla.javascript.JavaScriptException: Error while generating sprite image: invalid width (0) (e:\CKBuilder\src/lib/image.js#186)

Change History (5)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending

I was not able to reproduce this. Please provide more details.

I have chosen basic editor removed all plugins agreed to conditions and downloaded the package.

comment:2 Changed 6 years ago by Wiktor Walc

It's about the command line builder and it is related to the lack of icons in the moono skin

comment:3 Changed 6 years ago by Wiktor Walc

Status: pendingconfirmed

@garry.yao - can you check again?

comment:4 Changed 6 years ago by Piotrek Koszuliński

When executed with -s option it still throws an error:

Building skins
Exception in thread "main" org.mozilla.javascript.JavaScriptException: Error while generating sprite image: invalid width (0) (e:\CKBuilder\src/lib/image.js#186)
	at ckbuilder.lib.image._c_anonymous_6(e:\CKBuilder\src/lib/image.js:186)
	at ckbuilder.lib.image.call(e:\CKBuilder\src/lib/image.js)

Without -s it WFM. However, editor built this way doesn't work because config.plugins is undefined. It should be an empty string.

comment:5 Changed 6 years ago by Wiktor Walc

Resolution: fixed
Status: confirmedclosed

Fixed in CKBuilder 1.6.1.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy