Opened 7 years ago

Closed 7 years ago

#9663 closed Bug (fixed)

Insert HR in table head crashes browser

Reported by: Garry Yao Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: Cc:

Description

  1. Open replacebyclass sample;
  2. Put cursor inside of the first th of the contained table;
  3. Click on "Insertion Horizontal Line"
  • Actual: Browser crashes.

Change History (3)

comment:1 Changed 7 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 7 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: assignedclosed

Fixed with git:abd4582.

While-loop inside editable#insertElement was falling in infinitive loop. It's because of some problems with splitBlock, but it turned out that there's a second problem - DTD for TH doesn't accept flow elements (e.g. <hr>). Fixing this stopped while loop. I suppose that splitBlock is still broken but I doesn't affect any known case.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy