Opened 12 years ago

Closed 12 years ago

#97 closed Bug (worksforme)

IE7: "Error: no such interface supported" when opening custom file browser

Reported by: afranco@… Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: IE IE7 WorksForMe Cc:

Description

Effect

IE7 pops up the following error: Error: no such interface supported Custom file browser window cannot be opened in IE7.

Steps to Reproduce

  1. Open an FCKEditor that uses a custom file browser in IE7 on Windows.
  1. Click the 'image' button.
  1. Click the 'Browse Server' button in the image dialog.

Comments

After debugging for a while I found that the error was happening on line 157 of editor/dialog/common/fck_dialog_common.js :

window.open( url, 'FCKBrowseWindow', sOptions ) ;

The window object at that point seems to look like a valid object, and the window.open function prints out normally as:

function open () {
    [native code]
}

For some reason however, when window.open is called on that line, the "No such interface supported" error occurs. I attempted to put the window.open call into a try{} block inside a loop to see if subsequent calls would work, but to no avail. The window would not open on the first or subsequent calls to the method.

Change History (2)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: IE IE7 WorksForMe added; ie ie7 removed
Milestone: FCKeditor 2.4

I was not able to reproduce it. I've pointed the file browser to a simple HTML page, like "/somedir/somefile.html", and it opened correctly. I've tested it with PreserveSessionOnFileBrowser set to "true" also, with the same good results.

The fact that could give us some hints is that it happens only with your custom file browser. What do you have inside "url" in the window.open call. Try alert(url) to be sure about its value. Do you have PreserveSessionOnFileBrowser set to "true"?

comment:2 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Resolution: worksforme
Status: newclosed

Resolving as expired

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy