Opened 6 years ago

Closed 6 years ago

#9737 closed Bug (fixed)

IE10: CKE 3.x - We can't open CK Editor Context Menu for elements in editor body

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.6
Keywords: IBM Cc: Damian, Teresa Monahan

Description

In IE10 we can't open Context menus for any elements in editor body.

To reproduce the defect:

  1. Open any CK Editor sample & insert a table.
  1. Keep cursor inside a table cell, right click the mouse or press Shift + F1o to open Context menu.

Issue: Nothing happens.

Reproduced on build http://rev.ckeditor.com/ckeditor/trunk/7664/_samples/replacebyclass.html

Change History (8)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

DUP of #9378

comment:2 in reply to:  1 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

DUP of #9378

@J.swiderski defect 9483(which is marked as duplicate of 9378) & defect 9378 still not fixed in 3.6.x. Those issues are still reproducible in 3.6.x stream, i have checked it on rev ​http://rev.ckeditor.com/ckeditor/trunk/7664/_samples/replacebyclass.html. Could you plaese re-open both those tickets.

comment:3 Changed 6 years ago by Jakub Ś

@satya I have checked both editors and menu works fine now. Could you recheck? Please remember that basic Copy/paste show only if you have something in clipboard.

comment:4 in reply to:  3 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

@satya I have checked both editors and menu works fine now. Could you recheck? Please remember that basic Copy/paste show only if you have something in clipboard.

@J.swiderski Have u tried using the sample that i provided above http://rev.ckeditor.com/ckeditor/trunk/7664/_samples/replacebyclass.html. Also check what Browser mode & Doc mode that you are using. I have Browser Mode: IE10 & Document Mode: Standards. In the above build I can't open Text or Background color drop downs and also i can't open Context menus. But all of them are working properly on nightly build which has 4.0 version of CK Editor.

comment:5 Changed 6 years ago by Teresa Monahan

I can also reproduce this issue on the 3.6.5 (SVN) builds. The text and background color panels and spell check toolbar menu do not open. Also the context menus do not display for any element in the editor contents (links, table, images etc). As Satya said, it is important to use IE10 with Document Mode: Standards and a 3.6.5 build. @J.swiderski - are you still having trouble reproducing this?

comment:6 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: closedreopened

comment:7 Changed 6 years ago by Jakub Ś

Status: reopenedconfirmed

CKEditor v4 works; both git and release versions work.

CKEditor v3 it doesn't work here http://rev.ckeditor.com/ckeditor/trunk/7664/_samples/ but when I try my local SVN version everything works as expected. Perhaps only release code is affected.

The same thing happens with #9378, #9483.

comment:8 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: confirmedclosed

Fixed with [7673].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy