Opened 6 years ago

Closed 6 years ago

#9758 closed Bug (fixed)

Anchor does not get placed on selected text.

Reported by: jeffreydev Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0.1
Component: Core : Selection Version: 4.0
Keywords: Cc:

Description

When placing anchors within a inline ckeditor the link sometimes does not get placed within the selected text but in front, behind or sometimes in the middle of the selected text.

This bug does not always happen, currently I am unable to reproduce this bug 100% of the time, so it might have something to do with browser/system performance.

jsfiddle for testing: http://jsfiddle.net/32kYU/

To reproduce (sometimes):

  • add text to first editor
  • add text to second editor
  • double click text in first editor to select and click the anchor button
  • add anchor

Or:

  • add text to editor
  • select text
  • add anchor (ctrl + l)

Attachments (1)

2012-12-05_1457.swf (882.7 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by jeffreydev

Actually after some more testing I also have this problem on the demo page (http://ckeditor.com/demo#inline).

To reproduce:

  • clear the upper right text (next to CKEDITOR GOES INLINE)
  • enter multiple lines of random text (fdfsdf sdiuhew fds sdjfh ewr)
  • select words by either double clicking or selecting by dragging the mouse
  • click the link button in the toolbar
  • click the unlink button after the links are added and repeat the process
  • repeat this about 10 times and im fairly sure it will happen atleast once

Have tested this in firefox, chrome. So far it doesn't seem to be happening to me in internet explorer.

comment:2 Changed 6 years ago by Jakub Ś

Keywords: anchor link inline focus removed
Status: newconfirmed
Version: 4.0.1 (GitHub - master)4.0

I was able to reproduce this problem in Firefox, Chrome, Safari and Opera (IE works fine) from CKEditor 4.0 (4 beta looks fine).

Please see attached video to see how can it be reproduced (seems that rtl selection is the key).

@jeffreydev if there are other ways to reproduce this, please provide video as well.

Changed 6 years ago by Jakub Ś

Attachment: 2012-12-05_1457.swf added

comment:3 Changed 6 years ago by jeffreydev

As an addition to this, bug (I am not sure if it is the same or if it is just a similar bug):

  1. Goto: http://ckeditor.com/demo#inline
  2. Clear all the text on the right side of CKEDITOR GOES INLINE.
  3. Enter multiple lines with the same word (in my case I used "bla"), so for example:
    • bla
    • bla
    • bla
    • bla
  4. Select each "bla" from right to left, start with the top one and add a link to them.
  5. The selected "bla" does not always get the anchor, and sometimes it selects the previous selected "bla",

comment:4 Changed 6 years ago by Piotrek Koszuliński

Component: GeneralCore : Selection
Milestone: CKEditor 4.0.1

I reproduced it on FF and Chrome. I couldn't on Opera and IE9. Perhaps it's related to how we lock selection, because that has changed after Beta.

comment:5 Changed 6 years ago by Piotrek Koszuliński

Ah - and there's no need to clear some content - I reproduced it on inline demo on the random selections in right column.

comment:6 Changed 6 years ago by Jakub Ś

I couldn't on Opera

Try my TC (see the movie) - this can ba also reproduced in Opera.

comment:7 Changed 6 years ago by Piotrek Koszuliński

Similar issue: #9699.

comment:8 Changed 6 years ago by Piotrek Koszuliński

Patch for #9699 seems to fix this issue.

comment:9 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:10 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: assignedclosed

Fixed with #9699.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy