Opened 7 years ago

Closed 7 years ago

#9766 closed Bug (duplicate)

Insert space into table after long string fails

Reported by: Aaron Maenpaa Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

  1. Enter "source" mode.
  2. Paste in the following table:
    <table class="Basic" style="width:50%">
    	<tbody>
    		<tr>
    			<th>Lorem</th>
    			<th>Ipsum</th>
    			<th>Dolor</th>
    		</tr>
    		<tr>
    			<td>Lorem</td>
    			<td>&nbsp;</td>
    			<td>&nbsp;</td>
    		</tr>
    	</tbody>
    </table>
    
  3. Switch back to rich text mode.
  4. In the middle-bottom cell paste: "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
  5. Double click on the 'x'es to select them.
  6. Press <end>
  7. Press <space>
  8. Press 'a'

Expected: There's a space after the 'x'es and an 'a' Actual: The space is never inserted and the 'a' gets stuck on the end. Notes: The <end> is not strictly necessary, but it makes it repro consistently for me. Without the <end> sometimes I get the behavior I'm reporting and sometimes I get the expected behavior.

I've reproduced this in 3.6.3 (what we're using), 4.0 (the demo), and the nightly as of 2012-12-04.

Change History (2)

comment:1 Changed 7 years ago by Aaron Maenpaa

Repro's in Chrome, but not Firefox.

comment:2 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This is actually a duplicate of #9861.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy