Opened 7 years ago

Closed 7 years ago

#9765 closed Bug (fixed)

Toolbar Collapse command documented incorrectly on Accessibility Instructions dialog

Reported by: Satya Minnekanti Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0.1
Component: Accessibility Version: 4.0 Beta
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. Open any CK Editor sample, navigate to editor body and press ALT + ZERO.
  1. Accessibility Instructions dialog comes up.
  1. See the Command shown for Toolbar Collapse Command

Issue: it says Press Ctrl + Z which is incorrect it should say Alt + SUBTRACT

This is only happening in 4.0 & not in 3.6.x stream & it's a regression

Attachments (1)

9765.html (5.9 KB) - added by Olek Nowodziński 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed
Version: 4.04.0 Beta

If config.toolbarCanCollapse=true; is defined then dialog shows Alt+SUBTRUCT whne it is set to false dialog shows Ctrl+Z.

comment:2 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.1

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

It should show nothing, in fact.

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Component: GeneralAccessibility

comment:5 Changed 7 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

Changed 7 years ago by Olek Nowodziński

Attachment: 9765.html added

comment:6 Changed 7 years ago by Olek Nowodziński

Attached a sample to reproduce the issue.

comment:7 Changed 7 years ago by Olek Nowodziński

Status: assignedreview

Pushed a commit to t/9765, which solves an issue. This fix basically omits all the a11y help entries that contain a reference to the keystroke undefined in editor.keystrokeHandler.keystrokes.

comment:8 Changed 7 years ago by Piotrek Koszuliński

Owner: changed from Olek Nowodziński to Piotrek Koszuliński
  1. swapKeystrokes is called multiple times on one dialog open. I pushed commit fixing this.
  2. ALT+- keystroke doesn't work for me on FF (Linux and Win). There's CKEDITOR.ALT + ( CKEDITOR.env.ie || CKEDITOR.env.webkit ? 189 : 109 ) when on FF "-" is 173. Extracted this issue to #9827.

comment:9 Changed 7 years ago by Piotrek Koszuliński

PS. regarding 1. - if you tried to make this dialog aware of changes in keystrokes, then it couldn't work, because dialog's content is generated once, on first dialog opening.

comment:10 in reply to:  9 Changed 7 years ago by Olek Nowodziński

Replying to Reinmar:

PS. regarding 1. - if you tried to make this dialog aware of changes in keystrokes, then it couldn't work, because dialog's content is generated once, on first dialog opening.

Nope, I didn't. I'm aware of this fact.

comment:11 Changed 7 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:12 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Masterised git:4c8f77e.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy