Opened 10 years ago

Closed 10 years ago

#9796 closed Bug (fixed)

Editor outputs non-standart `strike` element instead of `s`

Reported by: Danil Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.1 RC
Component: Core : Styles Version:
Keywords: Cc:

Description

Editor with default configuration produces <strike> element when you execute Strike command. Neither html4 nor html5 standarts has no strike element. The nearest element to strike is s element, defined by html5. See draft specification: http://www.w3.org/html/wg/drafts/html/master/text-level-semantics.html#the-s-element

Change History (11)

comment:1 Changed 10 years ago by Piotrek Koszuliński

comment:2 Changed 10 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.2

comment:3 Changed 10 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:4 Changed 10 years ago by Guillermo

You might want to investigate and consider the <del> tag:

The <s> element is deprecated in HTML 4.01.
The <s> element is redefined in HTML 5.

The <del> tag is defined in both and was unchanged between HTML 4.01 and HTML 5.

comment:5 Changed 10 years ago by Danil

Both tags works fine and looks the same. But the <del> has more specific meaning than <s>. Use custom buttons or styles for <del>. It would be great to have a plugin, providing ins/del buttons...

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0.2CKEditor 4.1

The <s> element seems to be much more appropriate for the current user people have for the "strike-through" button. As defined in HTML5 it has the purpose of "representing contents that are no longer accurate or no longer relevant".

Still this is relatively important change in the editor behavior, so I'm moving it to a major version.

comment:7 Changed 10 years ago by Piotrek Koszuliński

Let's handle this issue after entire #9829 (with its subtickets). Thanks to automatic features' HTML forms unification we won't have any problem with backward compatibility.

comment:8 Changed 10 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:9 Changed 10 years ago by Olek Nowodziński

Status: assignedreview

Created branch t/9796@cksource that contains necessary changes.

comment:10 Changed 10 years ago by Piotrek Koszuliński

Status: reviewreview_passed

comment:11 Changed 10 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Changed <strike> to <s> in git:db6ffc3a857. Updated samples.

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy