Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#9815 closed Bug (fixed)

[moono skin] Can't edit fields in jQuery UI modal dialog

Reported by: Irina Butu Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0.1
Component: UI : Dialogs Version: 4.0.1
Keywords: Cc:

Description (last modified by Wiktor Walc)

I'm using full version of CKeditor 4.0.

If I display the control in a page then try to add an image and write the image URL everything seems to work fine.

If I'm using jquery ui and display editor in a modal, the image URL field seems to be readonly (I cannot write into it or paste a known url). Just upload is working.

The version of jquery ui used is 1.7.2.

Attachments (2)

TestApp.zip (1.5 MB) - added by Irina Butu 7 years ago.
ckInJQueryDialog.html (3.9 KB) - added by Wiktor Walc 6 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by Irina Butu

Attachment: TestApp.zip added

comment:1 Changed 6 years ago by Wiktor Walc

Description: modified (diff)
Status: newconfirmed
Summary: Incompatible specify Image URl with JQuerry UICan't edit fields in jQuery UI modal dialog

Indeed there is a problem with editing text fields in Image dialog window when CKEditor is opened in a modal dialog window.

This issue looks like duplicate of #5779, but I managed to confirm it in 4.0 using the attached project.

There is a big chance that the issue will be forever gone: http://bugs.jqueryui.com/ticket/4727 all we need is to wait for the next stable version of jquery UI.

Changed 6 years ago by Wiktor Walc

Attachment: ckInJQueryDialog.html added

comment:2 Changed 6 years ago by Wiktor Walc

Summary: Can't edit fields in jQuery UI modal dialog[moono skin] Can't edit fields in jQuery UI modal dialog

Put ckInJQueryDialog.html into the samples folder to reproduce the issue. It looks like the Kama skin is working fine. Only moono skin has this problem.

comment:3 Changed 6 years ago by Wiktor Walc

I think I managed to trace this issue to this single line in dialog.css for .cke_dialog_body:

	/* 	This one is required by Firefox 3.6. Without it,
		dialog tabs and resizer float outside of the dialog. */
	position: relative;

If I remove it, I'm able to type text in IE.

Note that this should not be there. If this rule is for Firefox, it should be in a separate gecko file.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.1
Owner: set to Piotrek Koszuliński
Status: confirmedassigned

OK. We'll target that position:relative for FF36 only, because this fix is required for it and it's more important than fixing jQueryUI. So on all other browsers this issue will be fixed.

comment:5 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/9815 (git:eaa08e6).

comment:6 Changed 6 years ago by Piotrek Koszuliński

I pushed one more commit - removing unnecessary fix for IE7.

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:8 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Masterised git:9025c89.

comment:9 Changed 6 years ago by Vincent Poirier

Component: GeneralUI : Dialogs
Version: 4.04.0.1

It still happens to me. Latest jQuery and jQuery UI + CKEditor 4.01. Not sure how to reopen a ticket. :S Here's a link to the non-working elements.(Happens on Chrome at the very least) http://test.rhsolutions.ca/_rhtools/rh-modules/module-xenocode/news.php Click the car image, once the jQuery UI Dialog is opened, double click the red car to open the properties dialog. Cannot change the fields.

Lemme know if I'm doing something wrong.

comment:10 Changed 6 years ago by psyafter

I'm agree, it's still happens in 4.0.1 + jquery 1.9.1 + jquery-ui 1.10.0

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy